6

When somebody calls my iPhone it rings on my Mac Yosemite, too - which is great!
But i would love to only have the visual hint and a silent ringtone!

Unfortunatelly i cannot find any settings for this issue.
Who has a solution for me?

enter image description here

5

I made myself a silent ringtone, named it Apex - which is 2nd in the list of available FaceTime tones, rather than change the default.

Renamed the original to Apex-old, then dropped the new file file in /System/Library/PrivateFrameworks/ToneLibrary.framework/Versions/A/Resources/Ringtones/ & set that as my ringtone in FaceTime itself.

I found no other way to persuade FaceTime to use custom tones; can't find where the default list of 'system' tones lives.
Simply dropping new sounds in there doesn't add them to the available choices, unlike iTunes etc.

As Mentioned in comments by Lukas, you can easily find silent ringtones for free through Google - https://www.google.com/#q=silent+ringtone+m4r

If you fancy making ringtones yourself, any AAC file of less than 40s can be quickly converted & dropped to iTunes with MakeiPhoneRingtone by RogueAmaoba

  • good solution, one can find a silent ringtone right here: google.com/#q=silent+ringtone+m4r – Lupo Feb 2 '15 at 13:47
  • 1
    Great solution, thanks. Too bad it won't work on 10.11 (at least not without additional effort). – mfilej Aug 27 '15 at 8:59
  • I haven't tried El Capitan yet, @mfilej - If you have a working method to do it on there, it would be worth adding to the answer, for future Googlers. – Tetsujin Aug 27 '15 at 9:05
  • @Tetsujin I tried the method in the other answer with the plist, seems to work so far. As far as your method goes, I think you'd need to reboot into safe mode and disable rootless mode. Seemed like too much hassle and likely to get reverted on OS updates, so I didn't try it. – mfilej Aug 28 '15 at 20:10
  • I found a solution for El Capitan, it involves booting into recovery but doesn't involve disabling SIP (although it might have to be re-done after every system update) apple.stackexchange.com/questions/158053/… – Brethil Oct 9 '15 at 11:45
6

There is the option in FaceTime preferences to choose a Ringtone. Unfortunatly there is no option for "NONE". As a workaround I found you can edit the file that sets this. The file is com.apple.ToneLibrary.plist

The file is located in:

~/Library/Containers/com.apple.tonelibraryd/Data/Library/Preferences/com.apple.ToneLibrary.plist

If the file doesn't exist the below command will create it. Running the below will not deactivate facetime calls only silence them.

sudo defaults write ~/Library/Containers/com.apple.tonelibraryd/Data/Library/Preferences/com.apple.ToneLibrary.plist ringtone "system:"

After you run this either logout and back in or run the below commands:

killall cfprefd
killall Finder

The part in the above command that is setting it to silent is the "system:", if you want to set it back to a sound ringtone you would do something like "system:crystal". Where as crystal is the name of the ringtone.

Not sure if anything else is reliant upon this file so make a backup before hand if the file exist on your system.

  • thank you + works "almost", when the caller calls it's silent ✔ - but when the caller hangs up before i catch the call i hear the Facetime ringtone twice loud?? (really strange behaviour!) – Lupo Jan 13 '15 at 15:21
  • 1
    Strange, I left feedback with apple to put a "None", or "Silent" setting for ringtones in a feature release. – tron_jones Jan 13 '15 at 15:28
  • Doesn't work on OS X El Capitan. – Dmitry Oct 14 '15 at 13:24
1

Try disabling sound for notifications under FaceTime preferences:

System Preferences > Notifications > FaceTime > Unselect the "Play sound for notifications" checkbox

  • Ben, this was my first idea, unfortunately it doesn't match/help! Thank you, anyway! - looks almost like a bug to me! – Lupo Jan 12 '15 at 11:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .