2

I have a problem which requires I regularly restart my iMac, up to several times a day, to get devices recognized.

When I re-connect a device, iPhone, iPad or iPod, I regularly get the message:

iTunes could not connect to this iPhone. This device is no longer connected.

They no longer show up as active devices in XCode.

When I plug a phone in, it asks me to confirm it should Trust this Computer but that doesn't make any difference.

Note that this is on re-connection. The devices are fine up until the point when I disconnect them. That doesn't change whether I "eject" them from iTunes or not.

Modal nature of problem

It seems that after this problem has started occurring, plugging any new devices in suffers a similar problem.

The problem survived a system restore from backup, which returned some 50GB of space to me. It originally showed up in Mavericks and I have since done an in-place upgrade to Yosemite. It's a mid-2011 iMac 21.5" with four USB ports.

The problem occurs regardless of whether the devices are connected directly into a USB port on the iMac or via the keyboard's extra ports. The devices are all getting power and show up on the System Report as being connected, eg:

USB2.0 Hub:

  Product ID:   0x0608
  Vendor ID:    0x05e3  (Genesys Logic, Inc.)
  Version:  77.60
  Speed:    Up to 480 Mb/sec
  Location ID:  0xfd140000 / 6
  Current Available (mA):   500
  Current Required (mA):    100

iPhone:

  Product ID:   0x12a8
  Vendor ID:    0x05ac  (Apple Inc.)
  Version:  7.01
  Serial Number:    52c05c8223d3efc793f2815e9d3dbcc018805880
  Speed:    Up to 480 Mb/sec
  Manufacturer: Apple Inc.
  Location ID:  0xfd143000 / 10
  Current Available (mA):   500
  Current Required (mA):    500
4

Using the following in Terminal is an alternative to resting your Mac.

sudo launchctl stop com.apple.usbmuxd

You still have to quit and relaunch iTunes or Xcode in order to see the device.

  • Agreed - that's what Andy Affleck came up with too. I've since applied this technique a couple of times. – Andy Dent Jan 24 '15 at 1:56
  • It's a circular trail :-). He references my posting on StackOverflow! (I'm not claiming any ownership of this, as I think I got it from someone at Apple) – mahboudz Jan 24 '15 at 3:02
  • That seems particularly appropriate given that this problem had me feeling like I was going in circles. I'm still leaning towards it being poor software handling of something triggered by an initial fleeting disconnection from loose hardware - the only time it happens now is when I've been moving devices whilst wired. – Andy Dent Jan 24 '15 at 3:14
1

(I wrote the blog post referenced by Andy Dent) in my case, my phone and iPad are connected directly to the computer (the iPad doesn't get enough juice from the hub to charge otherwise). So, I don't think it is a hardware problem. I have not found the trigger yet and despite my blogged solution, I still have to reboot at least daily as the problem comes back each time.

1

A partial answer has been found in this blog posting and many others suggesting removing /var/db/lockdown folder contents.

I found it after experimenting with replugging devices and looking in the console log to find errors such as:

sbmuxd[55]: AMDeviceConnect (thread 0x100781000): Could not connect to lockdown port (62078) on device 790 - eef3e6e83a5e15057e68f8e09c940fa5fa11bbde: 0xe8000084.

When I restarted after emptying /var/db/lockdown I had a new prompt in iTunes for each device:

Do you want to allow this computer to access information on “AndyD6plus”?

If you don’t allow access, you will not be able to manage or sync your iPhone with this computer.

After going through those alerts, entries were created in the lockdown folder and I now seem able to remove and add devices!

Update

I think I've also worked out what triggers this behaviour - once it goes bad it stays bad. My USB hub in the keyboard has a distinctly loose port on one side. I noticed that USB sticks also don't tend to register and sit solidly in this port. I forgot and put an iPhone cable in there. When I put some tension on that cable, shuffling the mess of devices on my desk, that iPhone vanished and then the lockdown problem came back.

So I am fairly comfortable with the idea that this is a combination problem - you start with a hardware vulnerability of a dodgy cable or port and then the OS can't cope with some resulting bad data in lockdown.

Lint Update Two factors have recently come to light - firstly being that the Lightning connector has an awesome capacity to both attract pocket lint and to mostly continue working. A thread on a local Slack recently discussed this with someone posting a photo of the amount of lint they had pulled out (using a wooden toothpick). I said I had got more out the previous week from mine and that was the second go in a couple of weeks. Unless your connector is pushing all the way in with a click you probably have some lint down there. Another giveaway is if the connector can rock slightly in the port. Note that a port which is considerably blocked will still charge OK.

Apart from that, restarting the iPhone is reliably fixing the issue for me as of 9.3.x

0

I tried this and it worked: Click on "Player" click on "Removable Device" You will see your device like "Apple iPod" or "iPhone" Click on your device click connect (Disconnect from host) ... click on "Ok"

(Your keyboard may not work ... try the step again and it will work)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .