5

I tried to install Xcode from the App Store. While it was being downloaded, a network problem occurred so the installation didn't complete. However, in the App Store, it appears marked as installed (so now I can't install it).

I don't see any uninstall option. Is there any way to uninstall it from the backend or something like that?

  • 1
    Xcode is an odd one since in the old days, you ran an installer. Then they sent the installer over the App Store so deleting the installer was just that - not uninstalling. Now the app is handled like other App Store apps - trash it and it's gone. Furthermore, people often have two versions of the app. Below are answers for each case - but it really matters exactly which version of Xcode you have and whether you need to run the old style installers to clean up a second install or a partial install. – bmike Sep 27 '12 at 15:35
7

In the special case of Xcode, the App Store downloads an installer app that you use to install Xcode. Look in /Applications for "Install Xcode.app" and delete that.

When you get Xcode installed properly, if you delete the installer, the App Store won't think it's installed and won't display updates.

  • 1
    This one worked for me. My situation was Migration Assistant migrated an Xcode 3.x for me on top of an Xcode 4 installed from Mac App Store. I tried trashing Xcode.app, sudo /Developer/Library/uninstall-devtools –mode=all, logout-login to no avail. The "install [Xcode]" button was reactivated at last after trashing /Applications/Install Xcode.app. – ento Jul 23 '11 at 10:34
2

Just throwing out some random suggestions:

  • First of all, remember to empty your trash.
  • Check ~/Music/iTunes and see if you can find it there. Try moving anything related to Xcode to the trash (and empty).
  • See if you have /Library/Developer. Maybe you can find any uninstaller there.
1

The app store is marking this as installed because there's part of a .dmg or some other file type somewhere hiding. If you go to the 'Purchased' tab in the App store you should get the option to re-install once you remove this file.

The App Store downloads its files to a temp directory before moving the .app file to your Applications Folder. The directory is

/Users/<USERNAME>/Library/Application Support/AppStore/

Go to that directory and look for anything that says Xcode and get rid of it. Then redownload and install from the App Store's Purchased tab.

1

This is the first time I ever heard of installing Xcode with iTunes, but try the Xcode commandline uninstaller: sudo Xcode directory/Library/uninstall-devtools --mode=all. If the uninstaller isn't there, (because you say it's incomplete), just delete the folder (usually at /Developer) or reinstall by downloading the .dmg that can be found at http://developer.apple.com/.

  • Man... XCode is not actually installed, that's the problem (thus Xcode binary is not in my system). Yes, some time ago, Apple published XCode on iTunes ($4 dollars, which is good for someone like me who don't want to get into the Apple Developer program which cost $99 yearly). So... the problem here is that iTunes thinks XCode is installed, but it's not... so how can I tell iTunes that XCode is not installed at all? – Cristian Jun 29 '11 at 2:41
  • Actually, @Cristian, you can download it for free from developer.apple.com – molle Jun 29 '11 at 3:31
  • Man, I was not able... some months ago I installed Xcode 3.X (on other mac) for free from apple's web site. But now I can't find a link to download the .dmg (and that's why I tried to download it from App Store, not iTunes... it was a typo, sorry, I'm kind of tired XD). – Cristian Jun 29 '11 at 4:30
  • XCode 3.6 is free. XCode 4.0 os not free. You do need a free developer account to download 3.6 (not the paid account). – Fake Name Jun 29 '11 at 5:02
  • XCode 4 is a payed app ($5, I think) and can be downloaded from the Mac App Store (not iTunes), or it can be downloaded for "free" if you are enrolled in a developer program (which costs $100/year). – lpacheco Jun 29 '11 at 9:53
0

Had the same problem with "Pickr.app." and found a solution. My problem was that it didn't show up in Launchpad, but the Mac App Store said 'installed'.

Go to /Applicatons/or ~/Applications and manually delete your app, in my case "Pickr.app", then reinstall.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .