5
  1. I am getting weird time in my click (attached is the screenshot)

enter image description here

  1. And it's not letting me change my time and giving me error "Could Not load Date & Time preference pane"

enter image description here

Any idea what's going on? Because of this error lots of app have stopped working such as chrome, sublime etc. My suspicion is that it has been corrupted by MAMP but can't confirm.

Thanks.

  • See here support.apple.com/en-ca/TS4350 – ecnepsnai Jan 11 '15 at 21:06
  • 1
    @ecnepsnai - Thanks but it has not fixed my issue :( – itsaboutcode Jan 11 '15 at 21:13
  • 1
    go to "System Preferences" > "Language & Text" > "Format", to check – nelson Jan 12 '15 at 16:06
  • @nelson - Thanks. It really fixed my issue. Basically when I clicked "Language & Text", I got the same error and when I clicked it again, it opened and fixed my time again. I still wonder, what makes it go wrong in the first place? – itsaboutcode Jan 14 '15 at 7:18
  • 1
    from your screenshot I notice the date & time format are all wrong, I think this make OS X unhappy. so change the right date and time and its region would be OK. I don't really know how it take place, it maybe relate with preference, I hear someone delete the global preferences plist file make this issue. anyway, great. the issue has been fixed. – nelson Jan 14 '15 at 7:41
1

I solved this problem by opening Disk Utility and selecting "Repair Disk Permissions" in OS X 10.9. I had used chown to change permissions and messed up my preference pane apparently.

1

Selecting the 'Language & Region' preference fixed one of my issues - now the Panes show up. I had an issue that the difference preferences were not rendering on the screen, to see the actual buttons and selections, I had to toggle the arrows at the top of the System Preferences window, and get a glimpse of the buttons, and then hope that I was actually selecting one. In any case, I now have panes that render, but I still can't change my Parental Controls to block specific web sites.

I can create a new user that I can change, but I just want to fix the 'family' account that I have. Best case is that I hope that there is some corruption going on that the disk utility will fix.

-2

There are multiple things that could cause this issue.

For the first one, the notorious, but (sometimes) helpful chown. If you have run terminal, and used chown to attempt to fix a system error, such as sudo not running due to it not being 'run as root' on an administrator account, you may have royally screwed over your PC. Yea, I did that exact thing once. I had to back up my files and wipe the disk.

And second on the list is attempting to change the user ID. This will mangle your PC's filesystem, and also require either a $250 PC repair bill, or another system wipe.

Last but not least, think, have you downloaded ANY programs from the internet? If so, what are they? There aren't many 'viruses', so to speak, for macs (yet), however, during a package installation, when it says 'Running Scripts', that may also mean 'Running chown and changing system files to the point of corruption', or even one of the many other destructive commands.

The third is more than likely the cause of your problems, as most users of any PC run into problems just by downloading a 'clean looking' program. 7 system wipes later, I still haven't learned that... ANYhoo, I hope your problem is solvable without wiping the system!

In the case that any of these did happen, the first thing to do would be to run disk utility from the launchpad, click on 'Macintosh HD' or whatever your drive name is, then click 'repair disk permissions'. If this doesn't help, you may be in for a system wipe, unless either you can fix it, or you pay a professional to fix it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .