I have an NFS export on my Ubuntu 14.04 machine. I can mount it just fine from the command line in Yosemite:

mount -t nfs -o rw server:/home/gbell2/iOS_apps /Users/Devel/iOS_apps

And immediately I can ls it. No problem.

Problem is, when I go into Finder and browse it, the little gray wheel at the bottom spins forever.

enter image description here

I cannot browse or open files in that folder from Xcode either.

I do not have icon preview enabled. My automount config just has Apple-generated stuff in it and while I know what automount is, these answers seem confused.

Another answer fingering automount isn't really clear either.

I've tried the mount options like rw,bg,hard,intr,noac,nfc,tcp with no change in behavior.

There aren't a large amount of files in the root folder of that share.

I'm not mounting in /Volumes because one of the above references indicates that doesn't work any more.

Mounting with SMB doesn't have this issue, though I'd like to avoid the permissions issues that I usually see when tying *nix systems together with SMB.

Any ideas or how to debug?

2 Answers 2


Oh my... turns out it was one of the .* files in the share. A simple rm of them all (excluding .git and/or .svn) and I was golden.

What a pain. Hours gone. I was unable to narrow down which file it was - a binary search failed so it may have been more than one.

Here's hoping lots of other people can be saved the time wastage.


I had a similar problem, and adding locallocks to the mount options fixed it for me.

(Alternatively, adding nfsvers=4 fixed it as well, but I ended up getting kernel panics on the Mac client, so I went back to the default NFSv3.)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .