1

Mail.app goes unresponsive whenever a specific Gmail account is added.

If I quit the process and go to System Preferences > Internet Accounts and disable the account, I can start Mail normally.

I can then use my other accounts (Exchange and Gmail) normally. If I then go to Preferences and enable the offending Gmail account, new emails are downloaded and then mail goes unresponsive.

I have tried removing and recreating the internet account, the mailbox, etc. I can verify that Mail downloads 1.5GB of data (approximately the size of the Gmail account) whenever I recreate the account. It remains unresponsive whenever the account is active.

I have tried the solution laid out here. It worked the first time this happened and now did not resolve the issue.

Can anyone think of any other steps to take to reset mail and get this issue fixed? Does anyone know the source of the bug?

  • did you try to disable all but Inbox IMAP folders in gmail web? – Ruskes Jan 10 '15 at 22:38
  • Yes, no noticeable difference. Mail.app still goes to "Not Responding" after downloading new inbox emails. – jscott Jan 10 '15 at 22:41
  • when you enable that gmail go to Mail - Window - Open the Activity and see it work. Does it eventually stop? if there is no activity that window will be empty. – Ruskes Jan 10 '15 at 22:51
  • Just magically started working after I added back only "All Mail" for the "Show in IMAP" setting for Gmail Labels. Which I have done several times. – jscott Jan 10 '15 at 22:55
0

I turned off all "Show in IMAP" label settings in the Gmail web console. enter image description here

I then added back only "All Mail." I restarted Mail.app and reenabled the account. Mail started normally and my email was available.

I still would like to know the source of the issue, but for now the problem is resolved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .