1

This window has been popping up repeatedly:repeated

I was sure that I already had the latest version of Java installed, but to verify I went here: https://www.java.com/en/download/installed.jsp

And sure enough I have the latest JRE. enter image description here

Then I went and followed the directions here to find the JRE via my command line: https://www.java.com/en/download/help/version_manual.xml#cmdline which says to enter:

$ /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java -version

and the terminal output was:

java version "1.8.0_25" Java(TM) SE Runtime Environment (build 1.8.0_25-b17) Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)`

Can anyone help me identify what I'm doing wrong here? I definitely have Java.

  • the command to find JRE in termianl is just "java version" – tron_jones Jan 10 '15 at 21:45
  • It is java -version you need a space and a - – user151019 Jan 10 '15 at 23:08
  • right. $java -version... the output was: No Java runtime present, requesting install. – BigRon Jan 10 '15 at 23:11
  • Would the problem simply be that I don't have the Java Developer Kit? – BigRon Jan 11 '15 at 0:50
3

I installed the Java Developer Kit and that fixed the problem. I'm not sure why that was needed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .