2

Something on my Mac keeps deleting the /private/tmp directory. I first noticed this was happening as I was investigating high CPU usage. The Console was full of errors like the following:

1/10/15 10:27:52.529 AM com.apple.xpc.launchd[1]: (com.apple.quicklook) Service only ran for 0 seconds. Pushing respawn out by 1 seconds.
1/10/15 10:27:53.556 AM com.apple.xpc.launchd[1]: (com.apple.quicklook[16286]) Service could not initialize: Unable to set current working directory. error=2, path=/tmp: 14B25: xpcproxy + 12907 [1227][1016C726-9ACF-3A24-9C51-A279F5C6B167]: 0x2

It turned out that /tmp was there, but it was a symlink pointing to /private/tmp, which was missing. I tried simply creating a new folder under /private and calling it "tmp" and to my surprise that worked. Until a few days later, I got the same runaway CPU, found the same errors in Console, and discovered that /private/tmp had been eaten once again.

I've tried all the repair options in Disk Utility and DiskWarrior. I've looked at scheduled processes with a 3rd party utility called LaunchControl, and didn't see anything obviously out of the ordinary. That said, I really don't know much about OS X internals, so the fact that nothing stood out to me isn't saying much.

I'm currently using the latest version of Yosemite. I should also note that my computer has been acting kind of flakey in general. For example, not staying asleep when I shut it. I've tried resetting the SMC several times, and even went so far as to reinstall OS X about a month ago. I'm not asking for help with these issues (if I did I'd write a separate post and be more specific). Just setting the context, in case it's relevant to the /private/tmp issue.

Thanks!

  • 1
    Normal OS X won't end up without a /private/tmp directory - files in it it might get deleted on startup or after a few days but the directory should be there - so I would suspect an non Apple program – Mark Jan 10 '15 at 17:22
  • As @Mark noted, a third-party app or utility is the prime suspect. You'll have to do some investigation of what is causing the problem by systematically eliminating the programs running at the time the problem crops up. – douggro Jan 10 '15 at 18:15
  • One problem is I don't know when it happens. What would be a good way to get immediately notified when it happens? – Jesse Baer Jan 10 '15 at 18:30
  • I used a similar solution found on discussions.apple.com/thread/6717857?start=0&tstart=0 but I have not yet found the root cause. The delay in removal of /private/tmp seems to be about 3 days. – Citricguy Jan 27 '15 at 1:06

You must log in to answer this question.

Browse other questions tagged .