9

Every time I open my TextEdit app it starts with the File Open dialog open.

How do I stop this?

3
  • This has irritated me forever - your question prompted me to actually have a look for how to fix it. Invicta just beat me to it, so +1 for everybody :)
    – Tetsujin
    Commented Jan 10, 2015 at 11:24
  • What OS? Could you also provide the screenshot?
    – nicael
    Commented Jan 10, 2015 at 13:34
  • Yosemite - 10.10.1 (14B25). And it's simply the File Open dialog.
    – Snowcrash
    Commented Jan 10, 2015 at 14:30

1 Answer 1

15

I find this behaviour irritating too. I believe Mountain Lion introduced a new Open dialog to provide the option to save a new file in iCloud so that it’s available from other iOS devices. You can disable this feature by going to System Preferences > iCloud > iCloud Drive Options then untick TextEdit.app and any other apps that have a similar behaviour.

5
  • 1
    That fixes it. It's beyond irritating. It's a bug.
    – Snowcrash
    Commented Jan 10, 2015 at 14:32
  • 1
    This solution works for the same problem with QuickTime, too.
    – 2540625
    Commented Feb 3, 2019 at 0:00
  • Unfortunately the solution doesn't work for Script Editor (at least on Monterey) – even though the solution did work for Text Edit. Any ideas? Commented Apr 7, 2022 at 6:46
  • save my days. It works for me in macOS 13.2 Commented Mar 25, 2023 at 4:04
  • The path is slightly different (of course) with Ventura: System Preferences > iCloud > iCloud Drive > Options. Just one extra button to click is all.
    – Parapluie
    Commented Nov 9, 2023 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .