10

This morning I had an email in my Inbox from Google saying "We recently blocked a sign-in attempt to your Google Account (Date & Time: Saturday, January 10, 2015 3:01:26 AM UTC Location: Oxford, UK)"

They provide a link: https://security.google.com/settings/security/activity

This takes me to the following: enter image description here

Originally it showed me the IP of the attack. I then put "what is my IP" into Google to discover that it is actually my own IP, so I clicked the "this is actually me" box, and hence I can no longer show the screenshot with the IP.

My question is: what could have caused this? I went to bed before midnight; I think I closed the lid last night (in which case the machine should have been in sleep mode), but even if I didn't -- I usually leave it on some radio station when I sleep -- it hasn't given me any warnings before, so why now?

The page says it isn't my Mac that is causing the problem. But the only other device I have is my android phone and the Wi-Fi is disabled, and it doesn't have any 3G type Internet. I keep those things off to save battery. It did have Bluetooth on (I must have forgotten to turn that off days back).

I've also got a standard Apple issue keyboard and trackpad, and this morning the trackpad bleated about wanting new batteries.

That's it! That's all the electronic things I have. And a Wi-Fi repeater which plugs into the downstairs router via an Ethernet cable.

So what could this warning be? Someone else is attempting to sign into my account from my home IP? That's really unlikely. It is a family home, I doubt one of my family is trying to hack me, I would however be impressed if this were the case. I haven't handed down any old computer equipment either.

So I have no clue.

Can anyone think of any possible explanation?

5

This question was asked a while ago, I'm not sure if you've solved the problem. If you have, please enlighten me! I've been having the same issue (not quite every time, but almost every time I turn my Mac on). As with you, the location is my hometown.

I've done some Googling, somewhat ironically, and it seems to be a security issue with OSX Yosemite causing it, though I must confess I don't know the details.

This thread says:

"I received the same emails the same day I upgraded to OS X Yosemite and setup my Gmail account in Apple Mail. Its not a bug, but only security changes that have happened on Google's end of things. All you have to do is follow the link and enable "Access for less secure apps". Thats what I did and I haven't received the emails since."

However, I'm not a fan of allowing less secure apps, in case there is a genuine security issue (which this doesn't appear to be).

Another discussion says:

"I've found a way to solve it: just went to Settings, Internet Accounts and deleted my Gmail account. Put it back and it's working fine now."

It appears to be a fairly common problem (Google "Yosemite gmail sign in blocked"). I have tried the solution above and haven't received any more emails, but if it doesn't seem to work, I'll update this answer.


UPDATE: It happened again, which I'm fairly unchuffed with. After rooting around on Google, I found this:

Google may block sign in attempts from some apps or devices that do not use modern security standards. Since these apps and devices are easier to break into, blocking them helps keep your account safer. Some examples of apps that do not support the latest security standards include:

  • The Mail app on your iPhone or iPad with iOS 6 or below
  • The Mail app on your Windows phone preceding the 8.1 release
  • Some Desktop mail clients like Microsoft Outlook and Mozilla Thunderbird

To help keep your account secure, we may block these less secure apps from accessing your account, and you’ll see a “Password incorrect” error when trying to sign in. If this is the case, you have two options:

Upgrade to a more secure app that uses the most up to date security measures. All Google products, like Gmail, use the latest security measures. Go to Allow less secure apps and choose “Allow” to let less secure apps access your Google account. We don't recommend this option because it may make it easier for someone to gain access to your account.

So, bearing this in mind, it seems to be using a client of some kind causing the issue, which fits in with previous suspicions. So, for anyone facing this issue, be aware that your mail client may not be using the "modern security standards" that Google wants, and that this may the root of the issue. The fix is likely to be wait for an update to the client, or use a different one when accessing your Gmail account (or select "Allow less secure apps" in your Google settings).

  • Just wanted to add that in the case of using a software-based email client such as Outlook with Gmail, Google is probably expecting TLS connecting to the secure IMAP port these days, rather than the un-encrypted non-SSL/TLS IMAP port, etc. – rubynorails Nov 22 '15 at 3:20

You must log in to answer this question.

protected by Community May 28 '15 at 4:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .