4

Hopefully someone can help me. I've tried so many options. I purchased a used MacBook Pro, late 2011 model. The person I purchased it from said he wiped the hard drive, but when I got home, it seems he did that, however his login was still there.

So I did a disk utility, wiped the hard drive which checked out fine, got to the reinstall Yosemite page, but there is no hard drive icon, only the install Yosemite page. When I click continue I get this error, "An error occurred while preparing the installation. Try running this application again."

Images below are in order of error

!http://s30.postimg.org/nqvg41k1d/IMG_6344.jpg

!http://s29.postimg.org/mwvvef5af/IMG_6345.jpg

  • something missing here. how did you get pass the log in? how did you reformat the drive? – Ruskes Jan 10 '15 at 3:13
  • I did not see a log in, however I used disk utility to erase the drive. first I verified it and it came back ok, then i erased it and it stated the HD was good. – Julie Jan 10 '15 at 11:48
10

Just in case anybody else comes across this question, the steps to solve the system time/date issue mentioned above are as follows.

  1. Click on Utilities –> Terminal
  2. When the terminal window opens, type date and hit enter. What you will notice is that the date listed will be wrong. That wrong date is what is causing the reinstall error.
  3. To correct the wrong date –> type date followed by MMDDHHMMYYYY (Month – Date – Hour – Minute – Year)
  4. Exit and begin a new install, the problem should now be solved.
  • 2
    My date is not wrong :( – Caio Iglesias Aug 16 '16 at 20:54
  • This answer got me past that hurdle. – Robert Kerr Mar 25 '17 at 23:10
2

This is a problem that quite a few people have experienced in the past and it seems to come about for a variety of reasons and hence has a variety of solutions, here's a few you should try:

  1. FIRST - try resetting PRAM by restarting your machine and holding command-option-p-r immediately when the machine starts booting up. Keep holding all four keys until the machine restarts again and you hear the start up chime. Quite often this solves the problem straight away and you're good to go.
  2. If resetting PRAM doesn't work, you might want to have another go running disk utility and try verifying the drive which you're trying to install to.
  3. If none of the above work, you might want to try this solution which relates to an error in the system time and date settings.

Finally, if you're still not having any luck, give Apple Care a call and explain that you've just bought a second hand machine. They'll likely help you register the machine in your name as well which is kinda handy and they should be able to work through the problem with you even though the machines out of warranty... they're normally pretty good with this kind of thing.

  • Thank you so much. I will definitely try these options and will let you know. Yes, I have called Apple and was going to pay the $29 service fee, but they couldn't fix it either. But at least it got registered. :) – Julie Jan 10 '15 at 11:45
  • No problems, I hope it works for you. And welcome to the community, don't forget to come back here if you have any other issues :) You can also vote on questions and answers you like by clicking the arrows on the left and side and even answer some questions yourself - Good Luck! – JamiePatt Jan 10 '15 at 11:52
  • Thank you SOOOOO MUCH! The date solution worked. I've been working on this for 4 days and I don't even know how to thank you for helping. :) – Julie Jan 10 '15 at 12:22
  • No thanks needed, but if you like the answer click the little up arrow next to it to vote it up, voting up answers is one of the ways people receive reputation in these forums so that more experienced posters can keep helping people out. I also added the steps to the solution below just in case someone else comes across this question. Hope you enjoy your new Mac. – JamiePatt Jan 10 '15 at 12:40
  • I would love to vote it up, however i don't have enough reputation?? I just found this site by chance. As soon as I get enough, I will definitely vote it up. – Julie Jan 11 '15 at 1:54
0

If none of the above work, Go to the Disk Utility, Repair the disk permissions and verify the disk. Backup and Erase the disk, If any error occurs during the verification process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .