1

I would like to make a partition for Linux. Here's what diskutil coreStorage list gets me (identifiers omitted):

CoreStorage logical volume groups (1 found)
|
+-- Logical Volume Group 
    =========================================================
    Name:         Macintosh HD
    Status:       Online
    Size:         250140434432 B (250.1 GB)
    Free Space:   0 B (0 B)
    |
    +-< Physical Volume 
    |   ----------------------------------------------------
    |   Index:    0
    |   Disk:     disk0s2
    |   Status:   Online
    |   Size:     250140434432 B (250.1 GB)
    |
    +-> Logical Volume Family 
        ----------------------------------------------------------
        Encryption Status:       Unlocked
        Encryption Type:         AES-XTS
        Conversion Status:       Complete
        Conversion Direction:    -none-
        Has Encrypted Extents:   Yes
        Fully Secure:            No
        Passphrase Required:     No
        |
        +-> Logical Volume 
            ---------------------------------------------------
            Disk:                  disk1
            Status:                Online
            Size (Total):          250140434432 B (250.1 GB)
            Conversion Progress:   Complete
            Revertible:            No
            LV Name:               Macintosh HD
            Volume Name:           Macintosh HD
            Content Hint:          Apple_HFS

and diskutil list:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *251.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS                         250.1 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3
/dev/disk1
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:                  Apple_HFS Macintosh HD           *250.1 GB   disk1
                                 Logical Volume on disk0s2
                                 Unencrypted
/dev/disk2
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *314.6 MB   disk2
   1:                  Apple_HFS YNAB 4                  314.5 MB   disk2s1

Currently FileVault is turned off.

Previously, I tried to run the command (on Revertible: yes (decryption required), with FileVault key), but I couldn't tell if it worked. Afterwards, I turned off FileVault, and it stopped being revertible.

1

looking at your diskutil list output, your disk0s2 partition type is not correct; it should be Apple_CoreStorage, but has remained Apple_HFS (probably due to the interruption of the conversion process). If you are able to access the data on your internal disk, I would recommend backing up your data first. erasing your internal disk and doing a clean reinstallation of OS X, running Software Update to bring it up-to-date, and then restoring from your backup maybe the simple way.

if you want to do, you can find a way to fix that. Unfortunately I can not reproduce the problem, so I can not give exact instructions.

BTW: after making a backup, you can try disk utility app to repair disk, maybe it will solve this issue.

  • Thanks for the response! Just wondering, if "conversion progress" says completed, is it possible that the conversion was already done? How would I check? – a small bear Jan 10 '15 at 0:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .