-1

I've recently set up a print server with a Raspberry Pi and a Canon Pixma iP4850 printer using CUPS and have been able to print to it no problems with every Windows Computer in my house.

However, I haven't been able to connect to it with my Early 2011 MacBook Pro running OS X 10.10.1. (If I connect directly using USB, it can print fine.) The MacBook can ping the server and even open up it's CUPS web interface.

For my first attempt, the server was connected to the wireless network with the IP 192.168.1.139. I tried a windows laptop and it printed fine and in fact, the printer turned up as a bonjour wireless printer on my mac when I searched for network, I could connect, but couldn't print anything. I disconnected, and tried just entering it manually, but it wouldn't connect.

I had to move the printer, and it was too far away from the router to reliably connect wirelessly, so I then connected it to the modem. The new IP address is now 192.168.0.17 and again, I've been able to connect to it with windows computers, but again, unable to connect with my mac (it didn't appear on bonjour either).

This is a similar problem I had a while ago with another print server we had (this time an out of the box Netgear ReadyNAS), I was unable to connect or print through that either, so I'm pretty sure it's not an issue with the server.

If anyone has any ideas what might be the problem, it would be really appreciated. Thank you.

1

same prob here! nas: synology diskstation and printer: samsung ml2010pr do not work with yosemite. one possible solution is actual to send the print over a second mac running osx 10.6. but the prob. is not fixed. hopefully someone can fix this problem soon! thx.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .