I have an old hybrid ISO, WAR2BNE (Warcraft II: Battle.net Edition) in fact, that I am trying and failing to mount. The problem with the auto-mounting is that it uses the Mac portion and I need access to the Windows files.

A few web searches came up with various solutions, usually years old, that no longer work when attempted:

I'm not afraid of the Terminal, I'm just not sure where to start researching to solve this.

  • can Disk Utility see it & possibly mount it?
    – Tetsujin
    Jan 9, 2015 at 7:54
  • ever found how to do this? I'm having the same problem now.
    – The Oddler
    Sep 29, 2015 at 15:23
  • @Tetsujin -- Disk Utility sees devices and this is a file Nov 6, 2018 at 17:41
  • @TheOddler -- No, I tried using mount_cd9660 after attaching a pseudo-device with hdiutil attach (see wisbucky's answer below) but no go. My thought is that hdiutil attach only grabs the Mac partition Nov 6, 2018 at 17:42
  • I'm struggling to think what my train of thought was 3.5 years ago ;-) but I'd be tempted to say 'just burn it to disk', then see wisbucky's idea.
    – Tetsujin
    Nov 6, 2018 at 17:45

2 Answers 2


This worked for me to mount the Windows files in a hybrid CDROM. You should be able to do something similar for an ISO.

  • Run mount to list the currently mounted disks. Find the one for the disk you are interested in. E.g. /dev/disk2s1s2

  • Create a new directory under /Volumes, e.g. /Volumes/win

  • Mount to the new directory with sudo mount_cd9660 -er /dev/disk2s1 /Volumes/win. 9660 is the windows CD format, ISO 9660. Pay close attention to the device name, it is not the same as what is listed for mount. There is only one s, you truncate the extra s. So instead of /dev/disk2s1s2, you just use /dev/disk2s1.

  • Now when you go to /Volumes/win, it should have the Windows files, not the Mac files.

  • This sounds great except mount_cd9660 uses a device and not a file. Perhaps there is a way to mount the ISO as a device rather than a drive and then use these instructions? Nov 6, 2018 at 17:26
  • I used hdiutil attach filename.iso -nomount -readonly to create /dev/disk3s2 but when I run sudo mount_cd9660 -er /dev/disk3s2 /Volumes/win I get the error Invalid argument Nov 6, 2018 at 17:34
sudo mount_cd9660 -er /dev/diskx /mountpoint

where x is the disk number and mountpoint is any directory

  • The source is an ISO file not an actual device and the mount_cd9660 command doesn't appear to support this. Nov 6, 2018 at 17:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .