I have a Raspberry Pi I want to automount on my Desktop (Yosemite 10.10.1). I've installed OSXFuse (with the MacFuse option) and SSHFS both from https://osxfuse.github.io/. I'm using the password method for now and will establish certificates after I get this problem solved.

The following command works fine from Terminal:

/bin/mkdir /Volumes/RaspPi ; echo "mypassword" | /usr/local/bin/sshfs myuserid@ /Volumes/RaspPi -o workaround=rename -o password_stdin -o allow_other -o defer_permissions -ovolname=RaspPi

Placing it into a launchd plist worked the first day. The volume would get mounted and if I ejected it, launchd would remount it. But subsequently it has failed with the error:

kernel[0]: OSXFUSE: user-space initialization failed (4)

The RaspPi mountpoint gets created in /Volumes, but the volume doesn't get mounted.

The plist contains these lines:

    <string>/bin/mkdir /Volumes/RaspPi ; echo "mypassword" | /usr/local/bin/sshfs myuserid@ /Volumes/RaspPi -o workaround=rename -o password_stdin -o allow_other -o defer_permissions -ovolname=RaspPi</string>

I reviewed a lot of discussion about OSXFuse working via Terminal and not in launchd, but none of the solutions dealt with "initialization failed (4)". They all seemed to deal with a socket problem and error 57. I tried a few of those solutions, but they did not help.

Any suggestions?


I got it fixed by adding


More info about it can be found here OSX run script to mount sshfs at login with a plist file

  • I spent an hour yesterday debugging a sshfs plist I wrote. Adding this fixed it! Thanks!
    – Stratus3D
    Dec 28 '16 at 18:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .