As the title suggests I cloned my mac hdd using CCC and bootcamped and restored win 7 on the bootcamp partition.

It would seem that everything worked out as planned but the first thing I noticed was that chrome wouldn't launch. It would crash instantly. So I re-installed it which did nothing. I then proceeded to remove the application support folder for Chrome and then re-installed. Nope.

I then noticed that NONE of my applications that aren't from Apple (apart from Unity3d which actually runs) will start. They all "quit unexpectedly". I have tried to repair dependencies and I have controlled the integrity of my drive. It repaired a bunch of dependencies but couldn't find anything wrong with the disk. I have a hunch it has something to do with when I restored the windows 7 installation but I can't be sure of that.

Anyone have the slightest idea what's going on? How would I fix this without having to wipe the mac installation?

Thanks for reading!

Edit After having a look in system.log I can see something that might indicate that something is bad with the partitioning. Every crash looks like this:

Jun 28 14:47:53 MacBook-Pro ReportCrash[3461]: [CrashReport _extractBinaryImageInfoUsingSymbolicator] caught exception: Called memoryAtAddress: 0xa0a5b794, which is in an unmappable portion of [0x0 -> 0xffffffffffffffff] in PID# 3457. (0x1005cb796 0x100b750f3 0x1007b4ec6 0x10000494c 0x100004fc3 0x10085c362 0x100848b7a 0x100004ac0 0x100005956 0x1008477fd 0x10000541c 0x100007fb4 0x100008aa0 0x10000ad72 0x10000ab4f 0x10095f9dc 0x10000a256 0x1009534f6 0x1009533a9)
Jun 28 14:47:53 MacBook-Pro com.apple.launchd.peruser.501[295] ([0x0-0x9e09e].dk.Otee.Unity_Unitron[3457]): Job appears to have crashed: Bus error
Jun 28 14:47:53 MacBook-Pro ReportCrash[3461]: Saved crash report for Unitron[3457] version ??? (???) to /Users/phil/Library/Logs/DiagnosticReports/Unitron_2011-06-28-144753_MacBook-Pro.crash
  • If you open console app - is there anything useful or worth posting from /private/var/log/system.log - I would try to launch one 3PP app several times, and maybe repeat with a second app that is a bit different (don't run two Office apps or two adobe apps - make them from different vendors)
    – bmike
    Jun 28, 2011 at 12:45
  • I added a crashdump. What do you mean by '3pp'?
    – Phil
    Jun 28, 2011 at 12:56
  • Sorry - third party product. 3PP is software not made by apple. Would you also consider looking at four or five crashes - the individual report that lives in ~/Library/Logs/CrashReporter - the three lines that mention " Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: 0x000000000000000d, 0x0000000000000000 Crashed Thread: 0 Dispatch queue: com.apple.main-thread" are most interesting. If all of them have the same cause or not...
    – bmike
    Jun 28, 2011 at 13:45

3 Answers 3


Restoring any data to another partition won't affect your mac partition unless you have a serious hardware error and no amount of software steps will address that. Let's set aside errors with HD or RAM or MLB for a moment and make sure things are working.

Run a safe boot, then reboot back to OS X and dig a bit at the crashes.

Specifically, the three lines in each crash report will let you know why the system crashed each third party app.

Exception Codes: 0x000000000000000d, 0x0000000000000000 
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Once you get a feel for whether it's the same exception type, you can dig deeper. Like I commented - you could try repairing permissions or re-installing the latest OS X update you are comfortable (10.6.8 is the latest) but whatever you had before should rebuild any shared library code and try again with the 3PP apps.

Good luck - you will certainly learn something about how OS X apps load in this ordeal.


[ ... ]

Disregard my previous answer. I looked at the crash log again, and did a few searches and tracked down the following (source):

In a normal Crash Report there is an appended list of apps and utilities (the Binaries), which this crash report hasn't managed to capture...

That crash is happening very early in the launch and the Report is incomplete. The app is trying to use areas of unmapped memory and this can be caused by three factors: The Application or the Data (Your Library) and in rare circumstances, the OS.

So lets start by eliminating some possibilities:

Edited for your situation:

Create a new account (System Preferences -> Accounts), install Chrome, and see if you can launch it. If the application launches successfully, then it's likely your 3P apps are okay and the problem is something in the main account.

  • Answer edited. Disregard previous answer.
    – Jon
    Jun 28, 2011 at 16:03
  • Now that's a great answer! Awesome find - I'm really curious to see the crashes in this case.
    – bmike
    Jun 28, 2011 at 16:49

This is a Solution and not an answer. I wiped the disk clean and inserted it totally fresh into the mac. I installed Mac OS X from my original installation dvd and just proceeded as usual with that. In the installation procedure I was asked to copy stuff from an old mac and I chose the alternative to copy from another volume on the mac. Since I've got this kit to plug in any internal drive as a usb-drive I just plugged in the original still unscathed disk where everything was like I left it after I copied it. This restored all the programs and what not and they worked as usual after this procedure.

I convinced myself to just start over with a fresh bootcamp installation and bring over whatever I need from the old disk when I need it. Not the best solution but it can be good to know that the mac's function to "restore" from an old mac actually repaired what was broken. My mac os is exactly like I left it on the other disk.

Since the days of XP, I'm pretty used to starting fresh with windows so I'm actually looking forward to it a little bit..

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .