0

I am having a hard time connecting to my office server in which I am the admin of. I have recently wiped the hard drive and re-installed os x yosemite with os x server. I use a Windows 7 machine at home which I am attempting to connect to my mac server with. I know the public IP works because I can SSH and VNC in just fine. Up until the wiping of the server I had fully working VPN services so I know they work. That and pings go through to my public IP without trouble. I keep getting as far as verifying the username / pass and it hangs and then gives an error 629 message.

I have...

  • Pinged the public server IP with 4 successful packets, every so often some have weird times like 9ms.
  • Flat out turned off my home windows firewall and also tried adding the proper exceptions.
  • Have tried using os x server automatic wizard to adjust my router port forwarding/opening of ports, as well as tried manually entering my local server ip address and port to open in airport utility.
  • Tried pinging and then connecting to the local address instead of the public address.
  • Tried turning off all forms of encryption.
  • Tried resetting the usernames / passwords.
  • Checked the accessibility feature of os x yosemite and it says VPN is available publicly.
  • Turned off automatic VPN type and manually tried both L2TP and PPTP.
  • Tried adding all OS X VPN port exceptions in airport utility under the network tab.
  • Tried to VPN into local address instead of public address.
  • Tried adding a pre-decided key or shared secret and forcing L2TP
  • Hooking up my co-workers desktop Mac machines to VPN via local/public addresses. Both worked and they also can send/receive/administer file sharing on the server.

The error 629 from my Windows client side gave a report generator which pumped out a 500 page "summary" ... I will cut out the seemingly important details:

Installation Check: Unable to validate installed Remote Access components.

Phone Book Files: Device=WAN Miniport (IKEv2) <-- Weird because I don't think this should be IKEv2

Remote Access Event Logs

Event Type: Error
Event Source: RasMan
Event Category: None
Event ID: 20276
Description: : The connection attempt failed on port: VPN3-1 because of the authentication protocol selected. Check to see if the authentication protocol is supported in the operating systems at the client and server ends of the connection

Anything else needing to be copied from that error report, lemme know.

  • What about the router at the public-facing side of the network. Does it allow VPN pass-through? Anything in the Console logs on the Mini showing why the connection fails? Have you tried a third-party VPN client on the Win7 machine? – douggro Jan 7 '15 at 15:32
  • Well I was under the impression that with a mac mini and a time machine as my wireless base station that it takes over all control of my router settings. Including front faced settings. I thought... however if I knew I wouldn't be posting here lol. – GoreDefex Jan 7 '15 at 15:43
  • I have tried many times on my phone, laptop and other network desktop pcs to get to my routers ip and so far no luck. Usually at home on a Windows PC I would have access to my routers settings easily with the gateway address like 192.168.0.1 or whatever it defaults to via DHCP. – GoreDefex Jan 7 '15 at 15:44
  • Checking VPN connections on the inside of your network - "Hooking up my co-workers desktop Mac machines to VPN via local/public addresses." - isn't a valid test of connectivity. We can't rule out that the problem is a VPN pass-through issue on the other end of the connection either. Have you tried connecting from some other location with the Win7 machine other than your home to see if you get the same error? I'm smelling a VPN pass-through problem at one of the ends of the connection. – douggro Jan 7 '15 at 16:10
  • I think your right I have been leaning towards thinking that since it gets passed the connectivity side of things and hangs on the step where it has to verify username/pass. Then it actively rejects the connection. – GoreDefex Jan 7 '15 at 16:23

You must log in to answer this question.

Browse other questions tagged .