3

I just turned on my Macbook air this morning and now the top keys aren't doing anything (F1, F2, etc). I can't turn down my keyboard light or anything. I tried going to system preferences and checking "Use all F1, F2, etc keys.." option but I am still not able to do anything like turn down volume or anything. I am using OS X Yosemite Version 10.10.1 .

  • Do you have a USB keyboard you can attach and try? – tim.rohrer Jan 7 '15 at 14:00
  • (This isn't an answer) Can you modify the speakers level with the menu icon? – daniel Azuelos Jan 7 '15 at 14:19
2

This happened to me a while back... First, try just holding down the power button for 10 seconds, to force the MacBook to shut down, and then reboot it normally. That sometimes works.

Failing that, you could try resetting the SMC:

Resetting the SMC on portables with a battery you should not remove on your own

Note: Portable computers that have a battery you should not remove on your own include MacBook Pro (Early 2009) and later, all models of MacBook Air, and MacBook (Late 2009).

  1. Shut down the computer.
  2. Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
  3. On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.
  4. Release all the keys and the power button at the same time.
  5. Press the power button to turn on the computer.

    Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC.

Source: Intel-based Macs: Resetting the System Management Controller (SMC)

  • @bubersson u r welcome :-) – Greenonline Oct 22 '16 at 18:36
1

I had the same problem: after a visit to the Genius Bar, the top row all of a sudden would only function as "function" keys; Brightness Down, for instance, would only trigger Spotlight etc. and the volume controls wouldn't work.

After spending about an hour with Apple help, we tried the System Preferences box, resetting SMC and PRAM, re-installed the OS, and nothing worked. I took it back to the Genius Bar and they quickly diagnosed the problem: the tech who repaired the trackpad forgot to re-map the keyboard out of the universal factory setting to US English, which is a necessary step.

It took about 15 minutes and then I was on my way.

Hope this helps!

  • do you have more information on: > I took it back to the Genius Bar and they quickly diagnosed the > problem: the tech who repaired the trackpad forgot to re-map the > keyboard out of the universal factory setting to US English, which is > a necessary step. (sorry I am writing this as an answer but I don't have enough reputation to comment following a bounty on this same topic) – Kevin Farrugia Oct 9 '17 at 7:52
1

I had the same problem and it got fixed once I installed Karabiner-Elements and opened it. Here is the link: https://github.com/tekezo/Karabiner-Elements.

  • Thank you, that worked for me too. Rest not. Mojave, 2019. – leon Apr 11 at 8:04
1

I had the same problem with my MacBook Pro, I went into system preferences>keyboard>keyboard tab, there are 4 boxes that can be check marked. If the last one (4th one down) “Use F1, F2, F3 etc. keys as standard function keys”. If it has a check mark, uncheck it and you should be in business! otherwise if you hold down the fn button while pressing the “F” key you need i.e. brightness or volume it should work that way as well. It did for me anyway. Good Luck!

0

It seems it can be a Key-remapping issue related with a hardware security mechanism against malware (as explained in the last post in https://discussions.apple.com/thread/6545759). Apple uses in store a non-accesible software tool. Seems to me that Karabiner, mentioned in the last post, works similar. It was the solution for me after nor unchecking Function keys, user change nor SMC and PRAM reset did work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .