2

Recently, I noticed that on the files on my external hard drive are not shown in Finder. All folders can still be navigated, but the files are not visible. When I check the contents of these folders in terminal, I can see the files are still on those locations and can also be opened with VLC for example.

Does anybody know what the issue could be? I only found one similar question, where they suggested that the com.apple.IconServices was causing the problem, however the proposed solution did not help in my case.

I am working on OSX 10.8.5.

  • is it excluded from the spot light? – Ruskes Jan 6 '15 at 22:03
  • 1
    It was still included in spot light. I thought excluding it from spotlight would only influence the search performance, not the behaviour of Finder itself. I now have excluded the entire volume, but can still not see any files. Maybe it is useful to mention that the harddrive contains a bit less than 3TB of data. Navigating between the different folders remains however quick, so I don't think it is because the drive is too slow. – Jaspack Jan 6 '15 at 22:10
  • what kind of files are those (just VLC fvl) and are they hidden for some reason? – Ruskes Jan 6 '15 at 22:12
  • 1
    Most files are video files (.mkv and .mp4). I looked at some other locations on the same volume and sometimes the files are visible. The files are all visible. I made the hidden files visible and they were still not showing up. I can also see them in the terminal with only using ls instead of ls -A. Thanks for your responses! – Jaspack Jan 6 '15 at 22:21
  • Finder doesn't show hidden files by default. chflag hidden set the hidden flag [Hide item from GUI], You can use "ls -lO" to see the flags of existing files. – nelson Jan 7 '15 at 3:14
0

I realised that the only volume I was having issues with was a NTFS-formatted volume, for which I use Paragons software to write to the volume. I searched for a solution to my problem and found someone having the same problem: http://forums.macrumors.com/showthread.php?t=1280829

It turns out Paragon writes the files with read, write flags, AND also the execute flag, which causes the files to not be recognised by the Finder. To solve this, you simply have to put the flags to read and write using chmod 644.

Thanks for all the help!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .