6

I'm trying to reload NFS mounts on my machine. What has worked in the past is:

sudo dscl .
delete Mounts/
exit
sudo autmount -vc

But now I get the error:

automount: Another automount is running

Doing a

sudo ps -ax | grep automount

shows there's only one process (besides the grep command itself) that contains "automount":

admin% sudo ps -ax | grep -i automount
59770 ??         0:00.01 /usr/sbin/automount
60201 ttys018    0:00.00 grep -i automount

I've tried killing it and rerunning sudo automount -vc and sudo automount -vcu, but no luck.

Has anyone else encountered this error message, or have any ideas on how to fix it?

I'm running Mac OS X 10.10.1 (Yosemite) on my local machine. If it's useful at all, the remote file server is running Mac OS X 10.7.5.

  • Should the title of this question be: "How can I fix automount: Another automount is running?" – Jonathan Komar Aug 3 '16 at 20:21
1

I see a process autofsd, which is performing the auto mount, but I run Mac OS X 10.12.6 so maybe that is different.

When I run automount it updates the mounts (from the auto_master file)

0

I've been messing with autofs on OSX and run into this error occasionally. Try the following commands (the suggestion came from this blog)

launchctl stop com.apple.automountd
launchctl stop com.apple.autofsd
launchctl start com.apple.autofsd
launchctl start com.apple.automountd
sudo automount -vc

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .