I'm trying to set up a new Retina MacBook Pro, which is running OS X 10.10, by transferring data from my old MacBook, which is running OS X 10.8.6, via Thunderbolt. My old laptop is in Target Disk Mode instead of using Migration Assistant due to the OS mismatch (the new machine wouldn't let me migrate with Migration Assistant). As far as I can tell, this all matches what Apple says should work. However, I have ~350 GB in my home folder, and my new laptop can only see ~50 GB. What's going on, and is there any way to fix it?

A few things:

  1. I tried copying my data once already, but almost nothing got copied (I think even less than the ~50 GB).

  2. I can't update my OS on my old laptop, because I don't have enough space.

  3. I could try restoring from a Time Machine backup – it seems to see everything that way – but I don't have the right cables, so (until I can get those) I'm looking for a laptop-to-laptop solution over Thunderbolt. (I have too much data to use Wi-Fi.)

  • what about updated apps on the new computer? could it be it is refusing to copy since it can not recognize the files types?
    – Ruskes
    Jan 6, 2015 at 18:19
  • @Buscar웃: I'm not sure what you're asking. At any rate, new computer hasn't completed the OS setup yet – there are no apps, no users, nothing. Jan 6, 2015 at 18:20
  • You can migrate from target disk mode, what error did you get when you tried?
    – Tetsujin
    Jan 6, 2015 at 18:20
  • @Tetsujin: I don't get an error, it just doesn't see all of my data. Jan 6, 2015 at 18:21
  • see this: support.apple.com/en-us/HT202910 "Re-download or reinstall any other applications you've purchased from third parties using the instructions provided by the developer of the software you're using. " BEFORE transfer.
    – Ruskes
    Jan 6, 2015 at 18:22

1 Answer 1


While preparing for one last Time Machine backup, I found myself restarting both my old and my new laptop – and some combination of these things fixed the problem. I was able to restore from my old laptop overnight, and this answer is being posted from my new machine. If anybody has any further insight, I'd welcome it, but my problem is solved!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .