0

Since I upgraded to Yosemite on January 3rd, my Apple mail app is misbehaving. When I get new messages from gmail, they show up in the Unread and Today mail folders but not in the overall Inbox folder. After they are read, they disappear from Unread (of course) and are lost in the ether. If I search mail for a specific message, it finds it and indicates its either in an Important folder or simply in the inbox. Otherwise the message doesn't show up in Mail at all. Also the mail remains on the gmail server when I access it directly on the web.

I've tried to synchronize the mail accounts but nothing changes.

I also turned on iCloud and iDrive at the same time.

  • there is no Unread email folder in Mail. So you made one ? – Ruskes Jan 6 '15 at 20:48
  • Yes I created a Smart Mailbox and used the rule "Unread" so all unread messages start there. – Steve Gunther Jan 7 '15 at 13:33
1

Your messages are not gone.

Apple Mail is not displaying the Exchange or G-mail inbox properly.

I tested this with 2 systems: 1 on Mavericks and 1 on Yosemite.

The Mavericks mail worked correctly and the Yosemite would stop displaying the inbox. I was able to perform operations (read, flag, delete, move) messages on the Mavericks system and the actions would correctly show on the Yosemite system once I re-synced the mail application.

Furthermore, I only needed to click on my iCloud-based account and then go back to my Exchange account for the inbox to be displayed properly. However, after about 30-45 seconds it would again stop displaying.

This looks like an Apple bug.

I hope this helps and that Apple can fix this annoying bug soon.

0

The problem lies in the Mail - List view - with Preview Window.

Unfortunately as soon you look at the mail (without actually opening it), the Mail will mark it as viewed (since you did see it in the preview window).

The only way to keep email as not read till you actually click to open, is to remove the Preview window in the List view.

To do that just slide the dividing bar between the List view and Preview to the bottom till it disappears = no more Preview.

The Smart boxes you created (Unread and Today) can not keep messages as not read, as long you have the List View with Preview on. As soon as seen in Preview they will no longer be in Smart box, but should be in your Inbox and in your "archive" folder. Archive folder is a misnomer, it means "all mail", but it has to be enabled on the Google web site in the IMAP settings to be in Apple Mail.

0

There is an article that offers an extremely time-intensive solution (not a gueareneed fix)

https://www.davescomputers.com/problems-gmail-mac-yosemite/

The basic steps are:

1 Open the email client app on your Mac computer.

2 Log into Gmail in your web browser, not in the app.

3 Look for a button on the right top corner of your Gmail that looks like a gear and click on it. Then click on Settings.

4 Click on the choice for Labels.

5 Deactivate Show in IMAP as well as All Mail and then return to your inbox to save settings.

6 Now, close the mail client app you have open for Mac.

7 Go to preferences on your Mac computer and choose Internet accounts. Delete all Gmail accounts now.

8 Go back to your Gmail account, to the settings as described in steps three through five. This time, reactivate Show in IMAP and All Mail.

9 Now, reopen your Mac mail client.

10 Go once again to Preferences and choose Internet accounts as you did in step seven. Add back your Gmail accounts now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .