I have two 15" Retina MacBook Pros, a 2013 which is my work machine and a 2014 which is my personal machine. I'm trying to transfer some files between them using airdrop. Both have Yosemite on them and are on the same network. Both have been rebooted whilst on this network.

The 2014 MBP shows the 2013 MBP in airdrop and can drop files to it. In the 2013 MBP airdrop view, the 2014 MBP briefly appears whist the file is transferring and then disappears again.

The 2013 MBP does not see the 2014 MBP at all. Nor my iPhone either. And I cannot transfers files to the 2014 MBP.

I completely flummoxed by this. The only difference I can see is the hardware. I've check firewall settings, sharing preferences, disk permissions and any thing else I can think of. But nothing seems to get the 2013 MBP to see the 2014 MBP.

I've also just noticed that the 2013 MBP cannot see any of the local shares.

Any ideas whats wrong?


  • 1
    The new Airdrop is just so flawed. Doesn't work (or only after a long period) between my 2014 retina and my 2011 pro half of time, I resorted to Infinit now. Wish Apple would improve Airdrop but it has never been the state of the art file transfer protocol they advertised it.
    – thibmaek
    Apr 22, 2015 at 23:29
  • Have you found a solution? Oct 23, 2015 at 11:28

2 Answers 2


I found the answer. Something in the side bar preferences was messing with the system. I deleted this file from the 2013 MBP (which could not see the other machine or network drives):


and rebooted.

Then everything came back online and started working.

  • Please put the solution into your original post, please.
    – IconDaemon
    Jan 6, 2015 at 13:36
  • 1
    It's not turned out to be a solution. The 2013 MBP is still not seeing anything in airdrop. Nuts !
    – drekka
    Jan 12, 2015 at 3:16

I have a similar ongoing problem with a late 2012 iMac and a mid 2014 15". I've found that signing out of and back into iCloud is a temporary fix. My suspicion is that new Airdrop leans heavily on a lot more services than original Airdrop.

Another option is to Select 'Don't see who you're looking for' in the Airdrop windows on both machines and select 'Search for an older Mac'. This will revert to legacy mode and works as well as it did in previous versions of OS X.

Also check if your searching for 'Everyone' in the Airdrop window. If you're restricting to Contacts you'll need to check your Card in Contacts. In Contacts from the menu bar>Card>Make this my Card.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .