6

I am using OS X Yosemite. I am seeing 2 accounts on my login screen. One is my account and the other has the name "Other". What account is that? When I click on it, there is no username. When I try to shut down my computer, I am now prompted to enter my username and password. Previously there is no need to do so. I have tried the suggestion here How to get rid of the "Other..."-Account on the login screen? but that only hides the "Other" account. I am still prompted for my username and password when I want to shutdown. How do I remove/disable the "Other" account, not just merely hides it? Thank you for the assistance.

  • Wondering if you found a solution for this as I've also noticed this today. Nothing new installed. – zerohedge Sep 23 '15 at 1:40
  • You have to enter a password at shutdown? Do you have a screenshot? – miken32 Sep 25 '15 at 2:43
  • Never mind, just noticed this is 8 months old! – miken32 Sep 25 '15 at 2:47
  • Another way to get an authentication pop-up at shut-down is if another account is logged in. If so, the pop-up is asking if you want to kill the other user. If you see this, and you HAVEN'T switched users since power-up, you've got an intruder. – WGroleau Sep 25 '15 at 17:21
6

This indicates you either enabled the root user or you connected to a directory service (Open Directory or Active Directory) for the ability to login with network accounts.

Directory Services: Open System Preferences > Users & Groups > Login Options

Look for a Network Account Server in the main pane of Login Options and edit accordingly if one is present.

Root User: "Open Users & Groups preferences, click Login Options, then click the lock icon to unlock it. If necessary, type your password, then click Unlock. In the Network Account Server section, click Join or Edit. Click Open Directory Utility. Click the lock icon to unlock it, then enter your administrator name and password. Do one of the following: Choose Edit > Enable Root User, then enter a root user password in the Password and Verify fields.

Choose Edit > Disable Root User.

Choose Edit > Change Root Password, then enter a new root user password."

https://support.apple.com/kb/PH14281?viewlocale=en_US&locale=en_US

  • This should be the accepted answer. – ProGrammar Mar 30 '17 at 15:03
4

I was able to remove the "Other" account from the login screen with this command:

sudo defaults write /Library/Preferences/com.apple.loginwindow SHOWOTHERUSERS_MANAGED -bool FALSE
0

I have enabled the root user acccount on my machine. As soon as I did that, "Other" now shows up on my login page.

To enable the root user account run /System/Library/CoreServices/Applications/DirectoryUtility.app, unlock the app, then click on Edit, Enable Root User, and key in a new root user password.

  • had to use the command open /System/Library//CoreServices/Applications/Directory\ Utility.app to open this in El Capitan 10.11 – user5359531 Feb 2 '18 at 22:26
0

Either try disabling the root user.

Go to System Preferences >> Users & Groups >> Login Options >> Edit >> Open Directory Utility and in the top menu choose Edit and then Disable Root User.

OR

Go to System Preferences >> Users & Groups >> Login Options and select List of users.

-1

When you bind a user to open directory you could see this as well, depending on the settings defined.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .