4

I can't get Finder to do a darn thing. Specifically, it won't open new windows, show files on the desktop, or be the app in focus when I click its dock icon or the desktop.

Weird! Fine, I'll relaunch Finder. That usually clears it up.

Er:

enter image description here

I can hit 'relaunch' on both of those Finder items, and it changes nothing. Neither did restarting the computer.

Apps can still manipulate files, and Alfred can open them - but not find them.

There are zero Finder processes open according to Activity Monitor:

enter image description here

What are my next troubleshooting steps?

  • Are there two Finder processes listed in Activity Monitor? If so, are the paths identical? (sample the processes and check line 5 of the output log) – grg Jan 5 '15 at 19:34
  • The plot thickens, @grgarside. There are zero finder processes listed in Activity Monitor. – hairboat Jan 5 '15 at 19:39
  • What does sudo ps -ax | grep Finder | grep -v grep return? – grg Jan 5 '15 at 19:41
  • @grgarside: Nada. – hairboat Jan 5 '15 at 19:42
  • Hmmm—intriguing! I guess you could try Safe Mode (⇧-boot) but it seems very strange that it won't let you start a Finder process given that it appears that none are running (which is usually what prevents a new Finder instance from running). – grg Jan 5 '15 at 19:45
5

Try restarting the LaunchServices database. Launch the Terminal app (Cmd+Space, "Terminal"), and type in

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

Then quit Terminal, restart your mac, and let us know if that fixed it.

1

The first thing to check would be Activity Monitor. This should show if the process or processes are actually still running as the force quit dialog can sometimes be stale. Furthermore, you can check for Finder instances by running the following:

sudo ps -ax | grep Finder | grep -v grep

This will show the path to any Finder which is currently running and also provide the PID.

You can also try booting into Safe Mode (hold Shift on boot). This should rebuild the LastApplicationState for Finder (and clear caches) which may allow it to launch correctly next time you boot normally.

Full discussion in chat

  • The Terminal command returned zero instances of Finder. Booting into safe mode and back into normal mode worked for me. – hairboat Jan 5 '15 at 20:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .