1

My MacBook Pro boots to the hated gray screen.

Things I have tried to fix this include:

  • Booting with CMD-R (boots to a grey screen)
  • Resetting the PRAM (boots to a grey screen)
  • Resetting SMC (boots to a grey screen)
  • Booted in target disk mode. Able to enter but unable to attach to other devices.
  • Attempted to boot from an install disk but all I get is the grey screen
  • Attempted to boot in Safe Mode. This gets about half way and then fails.
  • CMD-V on boot shows last posted messages as:

    SMCREADKEYACTION ERROR SMCREADDATA 8 FAILED
    considerRebuildOFPRelinkeKernel prebuilt rebuild has expired
    
  • Tried booting to Mavericks Install Pen Drive (same errors in the verbose mode)

I can boot into single user mode. I suspect I need to run the SMC update but I can't get into an OS to run it. Perhaps I've got a firmware bug/virus?

This is a 2008 MacBook Pro A1260 MacBookPro4,1

  • your SMC reset did not work, try again! – Ruskes Jan 5 '15 at 18:52
  • tried SMC resets more times than i can count – Charles Spencer Jan 5 '15 at 20:02
  • snow leopard install dvd manages to get to the GUI however also target disk mode launches (gets to the target disk icon/screensaver) but doesn't actually work (tried connect to 2 different machines) – Charles Spencer Jan 5 '15 at 20:03
  • can you boot in to Apple Hardware Test? – Ruskes Jan 5 '15 at 20:13
  • no. It will stay in a blank gray screen as long as I have "D" held down but the moment I release the "D" it goes into the failed osx boot. I've also tried option-d and command-d both with no success. – Charles Spencer Jan 5 '15 at 20:18
1

If you have your original discs load up the Applications Install disc and run the Apple Hardware Test from there. Look for memory faults. I doubt very much you have a firmware "bug", memory failure is much more likely and would explain the unusual hardware behaviour you're experiencing.

I had the same model which I initially bought around 5 years ago, this had the original OS installed (10.5.6). Immediately after purchase I used the install discs to wipe the machine totally clear of the previous owner's setup, no problems encountered during installation.

Everything seemed to generally work ok (one or two occasional random crashes) until I decided to wipe it clean following the retail release of 10.6. After trying (and failing) several times to install 10.6 I decided to substitute the factory 1GB RAM stick with a 512MB stick from another laptop. This time 10.6 installed perfectly, first go. Faulty memory explained the random crashes as well as the installation issues with 10.6. Incidentally, I tried running the machine after installing 10.6 with its original 1GB RAM. It would sometimes boot but was completely unpredictable - single user mode was always accessible though, like your setup.

  • I have isolated the problem as being a broken firewire. This explains why target disk mode doesn't function and also why deleting the firewire parts of /System/Library/Extensions allows the OS to boot without a problem? Is there a way to mark the firewire as "off limits"? Perhaps in the NVRAM?? – Charles Spencer Jan 6 '15 at 11:26
  • How did you boot in target disk mode if your Firewire port isn't working? Your original post said you booted in TD and successfully repaired the disk... – ScunnerDarkly Jan 6 '15 at 12:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .