1

I've tried changing DNS servers to OpenDNS's, I've cleared my history and website data from Safari, and I've uninstalled all extensions… but the browser just won't load Gmail! Whether I click on Sign In at google.com or enter gmail.com in my address bar, the page just never loads.

Not sure if related, but when I try visiting YouTube, Safari says the certificate is invalid. I click to proceed anyway, and the page automatically redirects to https://ad.doubleclick.net/N6762/adi/mkt.ythome_1x1/;sz=1x1;tile=3;ssl=1;dc_yt=1;kga=-1;kgg=-1;klg=en-gb;kmyd=ad_creative_3;ytexp=931369,937426,900245,902410,924645,946201,936112,9405772;ord=1426347126252949? It's a blank page. What's up with the auto-redirection? When I try to visit youtube.com again, I get served a site with no stylesheet or images. google.com loads without a problem although Safari throws up the invalid certificate warning as well.

Gmail loads fine on the Safari-only guest account, if it helps. My hosts file is ok. I'm using OS X 10.10.1 and Safari 8.0.2.

  • Have you tried another browser like Chrome or Firefox? Just to establish whether the problem is specific to the browser or the operating system. – Alistair McMillan Jan 5 '15 at 14:03
  • @AlistairMcMillan yes I've tried in both Chrome and Firefox, and Gmail loads fine in those browsers. – Rum Jan 5 '15 at 14:10
  • Is the timezone correct in the account where you encounter the issue? – Jules Dec 9 '15 at 12:41
1

A few things to check.

You said you uninstalled your extensions. Are they definitely gone? Check the following folder. It should be empty except for an Extensions.plist file.

/Users/YOURUSERNAME/Library/Safari/Extensions

You mentioned extensions but not plugins. Within Safari's preferences go to the Security tab and click on the button "Website Settings..." beside "Internet plug-ins". Uncheck anything you don't recognise there and try again. Especially, obviously, anything enabled for Google's sites.

Another thing to check is the proxy settings on your Mac. A quick way to access these is from the Advanced tab in Safari's preferences. There should be a "Change Settings..." button beside "Proxies" near the bottom of that tab that will launch System Preferences and take you right to the proxy settings. Hard to give you guidance beyond this, but look for any proxy settings that you haven't configured yourself.

One last thing to check for is malicious or buggy kernel extensions. While it's unlikely on Yosemite (as kernel extensions now need to be signed to load) it might be worth checking anyway. Open the Terminal application and type the following command it will list any kernel extensions that don't identify as coming from Apple.

kextstat | grep -v "com.apple"

Failing that a useful tool to help people diagnose problems is EtreCheck. Download and run it and paste the output into a Gist and update your question with the link.

  • Extensions: yes, that folder is empty except for the Extensions.plist file. Plugins: no suspicious plugins. Proxy settings: I haven't enabled/changed any of these so they are all unchecked/blank. Kernel extensions: nothing shows up when I enter that command in Terminal. Here's my EtreCheck report: gist.github.com/anonymous/d100d661240837f448fd Thanks for trying to help. This is frustrating because nothing seems to be wrong or out of place. Safari only stopped loading Gmail/YouTube recently (less than a month); I never experienced this before. – Rum Jan 7 '15 at 9:43
  • Do you know why you have SIMBL installed? There are/were a number of Safari plugins that used SIMBL. What do you have in /Library/Application Support/SIMBL/Plugins and /Users/YOURUSERNAME/Library/Application Support/SIMBL/Plugins? – Alistair McMillan Jan 7 '15 at 14:19
  • /Library/Application Support/SIMBL/Plugins is empty and /Users/YOURUSERNAME/Library/Application Support/SIMBL/Plugins contains Afloat.bundle, part of an application I use to keep a window always on top. I don't think it's the cause of this strange problem. – Rum Jan 8 '15 at 12:08
0

this discussion may relate to your question.

you might also try to repair the keychain, in case the problem lies there. to do this, launch Keychain Access in the Utilities folder. on the Keychain Access menu, select Keychain First Aid, then enter your Password, click Repair and press Start.

  • Thanks for that link. It seemed promising but deleting similar certificates didn't help, and my Keychain items do not need to be repaired. – Rum Jan 6 '15 at 3:15
0

Thanks for posting this, while I had a very similar problem recently, gmail and youtube would not load at all, using this information, I traced my problem to a plugin that I recently installed. I started uninstalling them one by one and my problem was caused by the Citrix plugin. Just a little more info, I didn't see you had that plugin, but I am guessing one of yours is the culprit. This was mine:

User internet Plug-ins: ℹ️

CitrixOnlineWebDeploymentPlugin: Version: 1.0.105 [Support]
  • Thanks, but I had already uninstalled all my plugins :( – Rum Jan 19 '15 at 2:02
0

It looks like you accidentally installed some kind of adware which injects advertisements into your browser, breaking it.

I suggest to download and run Malwarebytes' Anti-Malware for Mac. It will detect most adwares and remove them automatically.

Also, see this article from Apple's Knowledge base about how to remove adware.

Don't login into any account from your browser until you're sure it's adware-free. If you need a "safe" browser, you can either use Guest Mode or create another user account.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .