3

I have a problem with a 2012 MacMini. diskutil list shows an internal 500 GB 5400 rpm drive as having 0 Bytes.

It also states that it is unknown. Would TestDisk be able to reformat the drive?

Disk Utility will not let me format or partition, all options are greyed out. Any ideas on resurrecting a drive in this state?

The history of events:

I was on Yosemite 10.10.1 when I tried to use bootcamp to install Windows 10.

That did not work so well and I ended up with gray screen.

Trying to recover using the USB Installer with 10.10 does not see my HDD and does not let me format it.

10.10

Using the Internet recovery brings up the Mountain Lion Installer but can not proceed with the disk problem been: Not recognized.

ML installer

How do I format my HDD now and start over.

If I were to remove the drive from the mini and insert it into an external case, would I be able format it as JHFS+/GUID or FAT32/MBR?

  • Hey, how did everything turn out? Were you able to get the compiled version of TestDisk from the link I posted in the comments? – Vladimir Jan 9 '15 at 0:20
  • Unfortunately TestDisk nor PhotoRec were unable to see /dev/disk0 I tried to format the disk from a virtual box install of win10, but that option is not available in my virtual space. Maybe an install of Ubuntu or Mint will allow me to access a disk not associated within the virtual space but I seriously doubt it. My best option is to pull the drive from the MacMini located in the "upper" bay and install a 1TB SPINNER. And install a MX100, 512GB SSD in the lower bay. – Todd Jan 9 '15 at 1:04
  • That can work. One other thing you can try is the Target Disk mode (if you have a thunderbolt or firewire cable). It lets you access a hard drive from an external computer without removing it from the case. support.apple.com/kb/PH10725 If this doesn't work though, it might be best to just see a local computer expert. It probably doesn't even need to be a Mac guy. Just as long as the person knows a good amount about hard drives. – Vladimir Jan 9 '15 at 3:19
  • If Target Disk mode does work, be careful that you reformat the connected drive and not the working one. I did that once before and lost some data. – Vladimir Jan 9 '15 at 3:22
1

I'm not 100% sure this will work in your case since I think your partition map got erased (or something similar) but try this TestDisk tutorial.

I also used to know the site of a really nice walkthrough that helped me fix something similar on a flash drive a little while ago, but unfortunately the tutorial was only for Windows. Here's a site I found with some similar information for both Linux and Windows. You might be able to get this to work for you if you can run Linux off a flash drive or something.

Since you mentioned TestDisk, here's another guide for fixing the partition table of your disk using TestDisk. Again, this article is for Linux, but I assume TestDisk will work the same on both operating systems.

If it works, the first link will give you the cleanest, most-direct fix.

Using the last two links, you should still be able to fix the disk by first formatting the partition table to some universal format like FAT and then running your OSX recovery program to reformat the disk as it sees fit.

If you do go with the last two links, I would recommend trying to run PhotoRec on it first just in case you're able to recover any useful data with it. PhotoRec is made by the same folks who made TestDisk, but it's easier to use and is designed to just bruit force scan the disk and automatically pick out files that it can recover — actually "bruit force" might not be the right word here since that's just one of the options, but you get my point. :)

Good luck!

  • Thanks for the helpful information, testdisk and photorec require compiling to make an app, I just don't have the time as of the moment, I may just pull the drive from the mini and attempt to format it in an external, if I have time I will work on that this weekend, if that doesn't work I will replace the drive, Thanks Vladomir – Todd Jan 7 '15 at 0:47
  • @Todd I notice "Partition layout" is still active, do you try to change "current layout" to "1 Partition"? – nelson Jan 7 '15 at 2:29
  • Yes I did but no option to complete the partitioning – Todd Jan 7 '15 at 2:33
  • "Apply" is still grey – Todd Jan 7 '15 at 2:34
  • @Todd Hey, here's a link to the compiled versions of TestDisk and PhotoRec: cgsecurity.org/wiki/TestDisk_Download Good luck! – Vladimir Jan 7 '15 at 2:48
1

I replaced the drive with a new one.

  • 1
    Would you try Windows on it? – iskra Jan 11 '15 at 2:03
  • no thank you I will not try a windows installation, windows 10 is ugly, I know because I did a virtual box install, everything was fine on my external drive, but windows10 is a an ugly os, it took forever to find the "deep settings." – Todd Jan 11 '15 at 3:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .