I have spent 20 hours trying to install Windows 8.1 pro 64 bit on my MacBook Pro Retina MGXC2B/A

I created a ISO image of my Windows dvd, put it on my desktop.

Inside Boot Camp it asks for the Iso Image, I set this to read the ISO file on my desktop

Inside the Task Status window, I see the text "formatting selected drive...", which then changes to "Copying Windows files..."

When the loading % bar in this window reaches around 50%, a window pops up stating.

Can't download the software because of a network problem

I have tried this 10 times now, its the same error over and over, there is nothing wrong with my internet connection or networking, what is the issue?

  • For BootCamp and Virtual Machine installations, keeping the installation media on the same device as the installation target can make things painfully slow. There's a lot of back-and-forth reading and writing that's going on on that single drive now. If you can, put the ISO image on a separate drive. Even an external drive.
    – Ian C.
    Jan 4, 2015 at 17:27
  • @IanC I will try this and get back to you, however i dont know if its the issue.
    – Ramja
    Jan 4, 2015 at 17:36
  • @IanC. That did not fix it, the error occurs at around 50%. same msg
    – Ramja
    Jan 4, 2015 at 17:44
  • @Ramja That's a full Windows 8.1 Pro or some OEM Windows 8.1 Pro DVD? What do you use as install media, a thumb drive?
    – klanomath
    Jan 4, 2015 at 18:55

5 Answers 5


I ran into this issue just now and fixed it. My computer used to be managed by my company and the catalogURL was changed to a company owned update server.

I fixed it by resetting it:

sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate CatalogURL
  • 1
    I saw this while trying to install the software for a printer at home. Deleting the CatalogURL, installing the software, and then setting the CatalogURL back to its original value worked perfectly.
    – Dan Reese
    Feb 4, 2016 at 15:39

UPDATE: How to download and install the driver files without using Bootcamp.

Using the web site How to identify MacBook Pro models, I determined your computer is:

  • MacBook Pro (Retina, 15-inch, Mid 2014)
  • Model Identifier MacBook Pro11,3
  • Configuration 15.4”/2.5 Quad-core i7/16GB/512-Flash
  • Model number MGXC2xx/A

Other Mac computers use one of the links below:

How to identify your MacBook Air

How to identify MacBook models

How to identify iMac models

How to identify Mac mini models

How to identify Mac Pro models

From here, I went to the web site: Boot Camp: System requirements for Microsoft Windows operating systems to determine which driver files to download.

The files, you need to download for your MacBook Pro, can be found at: Boot Camp Support Software 5.1.5640

This should give you an alternative to downloading from Bootcamp.

I believe "the creation of the usb install flash drive" can be separated from "the download of the drivers." You should be able to install windows first, then install the drivers later. This is what I did with my clean install of the windows 8 operating system. I believe this is still true. "See Install Windows support software" in the Install Windows on your Mac.

If you are having network problems, can you continue the install without having the "Download the latest Windows support software for Apple" box checked off?

If you do get windows to install without the downloaded drivers installed, you will need to be able to boot back to OS X. This can be done by holding down the option key at startup, then selecting OS X. Once, the drivers are installed, you will be able to do this from the desktop.

  • It looks like as of 10.11 (Boot Camp 6) Apple doesn't have direct downloads of the support software. Nov 2, 2015 at 21:42

"network problem" means: "I tried to download stuff, but it failed for some sort of reason you can't fix and neither can I, good luck and try again".

So basically, it might be a problem at Apple's distribution servers, a problem in the API providing the BootCamp assistant with the latest data on how to download the right files, or it could be a problem with a request timeout. There are so many things between an app trying to download something and the whole chain up to Apple's download server that could have gone wrong. It doesn't mean your internet is completely broken or that your network cable is bent just a bit too far ;)

Just go ahead and use the option to create install media without Bootcamp, and download the drivers yourself. If you have an older MBP with installation media, one of the disks is Windows-readable and contains a version of the BootCamp drivers as well. It's usually printed on the disk. Those hybrid disks were used up until one of the recent versions of the MBP that had a SuperDrive, just before Internet Recovery became a thing.


This happened to me the first time I download. I just tried again and it worked.


I download the files directly from


I unzipped the folder and added its subdirectories directly to the partially completed windows 10 efi boot that the bootcamp assistant had made (before it crapped out)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .