Recently, I attempted to re-install Mac OS X Lion on my 2007 iMac computer (EMC 2133), but during the installation process it got interrupted. After rebooting it just displays a blank grey screen with no apple. I think there is a problem with the firmware, because because here are steps I have taken to attempt to resolve the issue, which have not appeared to work:

  1. Boot using the Mac OS X Lion DVD by holding C. Screen remains blank.
  2. Boot into hardware test by holding D. Screen remains blank.
  3. Boot into safe mode test by holding shift. Screen remains blank.
  4. Attempt to choose boot device by holding option. Screen remains blank.
  5. Boot into single user mode by holding Command - S. Screen remains blank.
  6. Reset parameter RAM by holding option - Command - P - R. Hold until system reboots at least three times, but after rebooting again the screen remains blank.
  7. Boot using Disk Warrior 4.4 DVD by holding C. Screen remains blank.
  8. Boot using Tech Tool Pro DVD by holding C. Screen remains blank.
  9. Taking out the hard drive and re-initializing it on my older eMac with Mac OS X Panther. The hard drive re-initializes OK but it doesn't change anything else, so it appears to be a firmware issue.
  10. Boot into Apple Firmware Restoration CD 1.3 by holding the power button for a long time according to this link https://discussions.apple.com/thread/3962770?start=0&tstart=0. I don't see the 3 quick blinks followed by 3 slow blinks then 3 quick blinks of any LED or tones, but instead hear one long tone and the computer starts up. I put the firmware restoration CD into my DVD, but the screen remains blank.

A year or two ago I had installed rEFIt on my Mac and had it successfully booting to various devices. At that time I think I had Mac OS X Lion installed. At some time later I removed rEFIt and installed Mac OS X Mavericks, which worked without a problem. Then a few days ago I decided to try reinstalling rEFIt (I should have probably used rEFInd instead, but rEFIt had worked previously for me, so that is why I had tried to use it again). This is when I started having issues with booting into my iMac, but even removing rEFIt and re-initializing my internal hard drive has not resolved the issue.

Does anyone have any suggestions? Is there anything else I can do to fix my iMac? TIA.

UPDATE:

Please note that I clarified the steps I took for firmware repairs in step 10.

UPDATE 2:

OK, I now see from here https://support.apple.com/en-us/HT202768 that the long tone from step 10 means that an EFI update is in progress, but even if I leave the computer on for a long time, the update does not appear complete. How long should it take? How do I know when it has finished the update?

migrated from meta.apple.stackexchange.com Jan 4 '15 at 15:32

This question came from our discussion, support, and feature requests site for power users of Apple hardware and software.

  • So you are trying to downgrade from Mavericks (which you made work) to Lion. Do you know what interrupted the original attempt to instal. And can you install Mavericks again? – Buscar웃 Jan 4 '15 at 17:47
  • 1
    At this point I would be happy with re-installing Mavericks or Yosemite or any operating system. The install of Lion worked, and it got to the point of me entering in personal information, but at that point both the mouse and keyboard were unresponsive so I did a hard reset on the computer. – user8128167 Jan 4 '15 at 20:52

Agree with Tetsujin about doing an SMC reset.
I recently had the same issue - I had hard-powered-off the computer in the middle of booting, and my system would then just remain black-screened at boot. Resetting the SMC brought everything back to normal (able to do Recovery Mode, Choose Boot Disk or boot from internal drive as usual).

However, for me to reset the System Management Controller (SMC), the procedure was different. From Apple, for computer without removable battery:

  • Shut down the computer.
  • Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
  • On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.
  • Release all the keys and the power button at the same time.
  • Press the power button to turn on the computer.

Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC.

( SMC reset: http://support.apple.com/en-us/HT201295 )

This immediately solved my booting issues (just last week). Good luck.

  • Thank you for the suggestion. I hold down the Shift-Control-Option keys and the power button at the same time, and then release all the keys and power button at the same time. The computer then turns on all by itself without having to press the power button again. What could I be doing wrong? TIA. – user8128167 Jan 4 '15 at 21:17

All I can think of that you may have missed in the 'standard suite' of things to try first would be Reset SMC...

Shut down the computer.
Unplug the computer's power cord.
Wait fifteen seconds.
Attach the computer's power cord.
Wait five seconds, then press the power button to turn on the computer.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.