8

What I have: macOS 10.10.2(Yosemite) on an iMac mid-2011 + original wireless keyboard.

Suddenly, buttons for controlling iTunes (they are located on F7, F8 and F9 buttons) stopped working. Meanwhile, other buttons (volume, brightness, launchpad, etc.) still work.

The keys work in other applications but not with iTunes.

Where should I look to fix this? Notice, the issue happened before updating to OS X Yosemite.

  • but they work with other applications? – Ruskes Jan 3 '15 at 17:48
  • Yes, the keys work actually. But not with itunes. – Hast Jan 3 '15 at 19:00
  • Did you try to cycle the "Use all F1..F12" in keyboard preferences On/Off – Ruskes Jan 3 '15 at 20:14
  • @Buscar웃 this option works as it should (on/off Fn+F combination) for all keys (volume, brightness, etc.) except iTunes. – Hast Jan 3 '15 at 22:01
  • 1
    Does anyone have a solution that doesn't involve chrome? I have this issue but chrome does not appear to be at fault. – rck Jan 21 '17 at 8:45
19

I found this to solve the problem for me, thanks to Major Hayden!

...check your keyboard shortcuts in Chrome:

  • Choose Preferences in the Chrome menu in the menu bar
  • Click Extensions in the left sidebar
  • Scroll all the way to the bottom of the page
  • Click Keyboard Shortcuts
  • Look at the key bindings in the Google Play Music section
  • Remove them all by by pressing the 'X' icon next to them.
| improve this answer | |
  • This worked. But after a few days, the problem persists even though the shortcuts have been removed from Chrome. If I click in the textbox to add a shortcut, then the keys magically work. Has anyone else seen this problem? – Prateek Nov 17 '16 at 19:59
0

I also had this problem but instead of Google Music it was Plex in Chrome that was causing the issues, solved the same way, going to Chrome > Extensions > Keyboard shortcuts > clicking x next to the Plex shortcuts.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .