13

I have a MacBook Pro Retina mid 2014 running OSX Yosemite (10.10.1). I have connected an external 4k monitor (Samsung U28D590D), but I'm struggling to set the correct resolution. When I open "display" I don't get the same scaling-options on the 4k monitor as I do on the Mac internal display.

Here is what I see on my Mac Retina display: mac retina options

And this is what I see on my Samsung 4k monitor: enter image description here

As you can see, it's not showing the scaling options on the 4k monitor (Larger Text, More Space, etc...)

When I use 1920x1080 the icons and text is very crisp (hidpi), but everything is to large. The 3840x2160 resolutions is pretty crisp, but everything is way to small. The 3200x1800 (low resolution) is not crisp at all.

What I want is to use the "More Space" option as I do on my Mac display.

Is there any way to achieve this? The display is connected through displayport.

  • Any luck with the mini display port connection in getting 4k at 60hz for the 13 inch MacBook pro? – user118155 Mar 14 '15 at 19:42
  • 2
    Apparently I don't have enough rep to post an answer 😠but I had the same problem apple.stackexchange.com/questions/189962/…. The tl;dr is that the scaling options in the other screen are actually just 3840x2160 at More Space and then 1920x1080, i.e. that screen won't give you something half-way between for crisp, small icons but readable text. Unfortunately it seems the only real solution is to sell and pick up a 5k screen. – spikeheap Jun 12 '15 at 11:15
  • @jorgen.ringen did you manage to fix your problems with this monitor? Or did you finally buy other model? – jjimenez Oct 21 '15 at 22:38
  • I gave up! Don't think you're able to run anything above 1920x1080 in hidpi on 13" mid 2014 mbp. – jorgen.ringen Oct 22 '15 at 8:06
3

@jorgen.ringen, I am facing the same issue with a 13" 3Ghz Macbook Pro 11,1 (mid-2014). The reviewer in 9to5mac from the link you posted states that the HDMI input ports will only do 4k at 30hz, so the only solution (as he also states) is to purchase a miniDisplayPort to DisplayPort 1.2 adapter or cable. I went for the cable and am currently awaiting its delivery.

I played with SwitchResX lots. Several threads on the internets suggest overriding the EDID in an attempt to fix the Television=yes in System Report problem, using Picture in Picture mode and running the display off of two cables. Neither of which is very satisfying to me, as its either a) PIP is not for every day use or b) requires plugging two cables, making it further more difficult to mount my machine on a desk and take it off.

The DisplayPort cable will hopefully do the trick when it arrives. Meanwhile, I noticed there is some kind of firmware update on the product page of the monitor. It requires a Windows machine, so I have not yet tried it. I can't find a way to see the current firmware version in the display menu either, but Samsung state that its a "compatibility improvement update" or some such. There is no changelog as to what changed since the previous version, or any explanation as to how that potential update might occur. To my knowledge, HDMI 1.4 supports Ethernet and maybe thats how the update takes place. If you have a Windows machine around, give it a try and report back please.

P.S. Unfortunately, the stupid SE comment policy will not allow me to post this as a comment. Whatevs.

  • Thanks for sharing! Let me know if you are able to fix the problem :-) – jorgen.ringen Jan 10 '15 at 14:08
  • Cable finally arrived? – youri Oct 2 '16 at 18:03
1

Do you get different options if you drop the refresh rate down to 30 or lower?

I'm guessing you don't get the same options simply because it isn't a retina screen; instead you get the resolutions your card/display can negotiate between them.

From Everymac This model supports a simultaneous maximum resolution up to 2560x1600 on two external displays via Thunderbolt. Alternately, it can support a single display up to 2560x1600 via Thunderbolt and a single 1080p display at up to 60 Hz, 3840x2160 at 30 Hz, or 4096x2160 at 24 Hz via HDMI.

  • I'm not able to edit the refresh rate (the dropdown is locked). As you can see in this review, he have the scaling-options on the same monitor: 9to5mac.com/2014/06/13/… – jorgen.ringen Jan 3 '15 at 16:42
  • he has neither the same computer, nor the same graphics card. That may have something to do with it. The retina-style resolution display is only a representation of what the numbers are telling you anyway, so I really wouldn't worry about that - but your machine is only just barely capable of running a 4k display so your options are likely to be different. Try another resolution first & then see if you can change the refresh, or even if it changes on its own when you change rez. – Tetsujin Jan 3 '15 at 16:50
  • Ok, thanks for your help. I'm kind of running out of alternatives here. I find it weird that a brand new rMBP don't support 2560*1600 in HiDPI. Running 1920x1080 on a 28" monitor doesn't feel right, and the text is actually way to big. So I think my only option left is to return the monitor and maybe buy a smaller where the 1920x1080 HiDPI feels more correct :-/ – jorgen.ringen Jan 4 '15 at 13:31
  • 1
    You could try SwitchResX perhaps. It might find more options – Tetsujin Jan 4 '15 at 13:36
  • Already tried it. – jorgen.ringen Jan 4 '15 at 17:44
0

I had the same problem. Macbook pro and Samsung U28E590 monitor just on 30hz.

I had ensured that I had USB-C to HDMI is 4k@60Hz.

Then then only other suspicious part was a cable. As you know cables came bundled together (for packaging purposes), then I tried to unwind all the curved parts of the cable (to make it more straight) as with this also cable interferences comes down (HDMI barely works on 4K@60Hz) as to make sure that interferences are minimised. Then as miracle start working monitor on 60Hz. So try to "flatten" the curved cable.

You must log in to answer this question.

protected by Community Mar 14 '15 at 20:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .