1

In Linux and bash I use alt + bksp to remove the word before the cursor.

On mac the option / alt + delete does not work.

e.g If you typed aaaa bbbb you will get aaaa afterwards

Any suggestion?

1

this functionality is provide by "readline", http://unixhelp.ed.ac.uk/CGI/man-cgi?readline+3. Most of keys are same as Emacs,

  1. so, you can type control+w to delete the word just before the cursor
  2. or for example,you can change the preferences of the terminal.app, use option as Meta key. Meta+Delete do the same thing
  • Cool! I didn't know ^w even when I'm using linux ;-P – daisy Jan 3 '15 at 6:00
0

Do you mean like Option + Shift + Delete?

  • Does not work in iTerm2 ... I typed "aaaa bbbb" and pressing that key results in "aaaa bbb" but I expected "aaaa" – daisy Jan 3 '15 at 3:33
  • That may be a limitation of iTerm. I don't have it, so im not sure. Does it work for you in other programs? – Teak Jan 3 '15 at 3:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .