My iPad 2 has a hard time locating our Wi-Fi network at home. About once a day it will find it and connect but only for an hour or so. It's not like I'm getting a "can't connect error", it just doesn't see the network. It seems to have no problem connecting to networks outside the house (coffee shops etc). Also, all of our other devices have no problem connecting to our home Wi-Fi.

  • What wifi router or access point are you using? Specific make and model. – Tyson Jan 1 '15 at 19:00
  • It's the Comcast stand router. Not sure it has a make/model available – munale Jan 1 '15 at 19:03
  • Did you try to delete that profile from Networks and create a new one? – Ruskes Jan 1 '15 at 19:37
  • Yes I have tried that – munale Jan 1 '15 at 19:39
  • One of the reasons i asked the make and model of the router was to determine what bands it had, I suspect other devices are connecting at 2.4 and the iPad is connecting at 5ghz which has less range. The comcast router DOES have a make and model. Since you described it with the word "stack" and it's Comcast I'm guessing its an Arris something, but can't help you much more until you can help determine the routers capabilities. – Tyson Jan 1 '15 at 21:53

I had the same problem with my iPhone a fews ago. Please reboot the router first. If this didn't work, then reset the router to factory resettings.

| improve this answer | |

First you should download a wifi signal strength analyzer app, so you can rule out having bad wifi. A quick google search let me find this app https://itunes.apple.com/us/app/wi-fi-sweetspots/id855457383?mt=8. Please post these results.

If you have good signal, then I'd try the steps from this article. Particularly:

  • restarting the I-pad
  • removing and re-adding the network to your saved wifi networks
  • delete other (nearby) networks so that the I-pad isn't trying to connect to them instead of yours

Also see this article on how to set up your wifi most effectively.

| improve this answer | |

I suggest that you contact your internet provider. It may be that the signal is weak or that when you are using your iPad you are using it in a 'dead zone' or part of the house where the signal is weak. There are apps which let you see exactly where 'good' and 'bad' reception areas are in your house but I would contact your provider first.

| improve this answer | |
  • I doubt that's it as I use the other devices in the same area – munale Jan 1 '15 at 21:38
  • 3
    Contacting Comcast is worthless advice... the most they will do is remote reboot the device and get off the phone. – Tyson Jan 1 '15 at 22:15
  • So I seem to have figured out what was wrong. Once you move more than 10 feet from the router it knocks you off. It works great if you right near the router. So I guess it's an iPad issue. I considered restoring the device but that would entail upgrading to ios8 which doesn't seem to be a great idea – munale Jan 2 '15 at 14:15
  • 1
    See my comment above, perhaps changing router bands would help. – Tyson Jan 3 '15 at 4:32

There could be a problem with the SSID interpreter on your iPad.

Try to manually connect to see it that works.

For this use your Terminal and copy paste following:

1- Turn On (if it is on you can skip this)

networksetup -setairportpower en0 on

2- Find the Networks (see it this shows it)

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

3- Connect (by replacing the SSID and provide the password)

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

The Scan result should look something like this:

wifi scan

The SSID is human readable name

The BSSID is the computer readable name for that interface.

Comcast also provides some instructions here: https://customer.comcast.com/help-and-support/internet/wireless-gateway-username-and-password/

| improve this answer | |
  • Pretty sure you just provided an OS X solution for an iOS device. – voices May 17 '16 at 11:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .