0

Question

Can you suggest a (series of) test(s) or monitoring that can show what is happening when the system fails, or some test that can show that the harddisk is borked or if some network issue is at hand?

Background

Upgraded from Mountain Lion. For a week or so it was like my box was on steroids, then I saw the beachballs more and more often. Took a backup, formatted my disk and re-installed Yosemite from scratch - no improvement.

Symptoms:

  • Last two times I started the box, Safari, which I just ran to save a wallpaper is stuck with a great big spinner. Nothing else can be run and even the top bar was missing. When I turned the computer off and on, I was sent to System utilities which made me suspect a harddisk failure is imminent and perhaps the root problem. I have now let the computer sort itself out - when I woke it, all tabs in Chrome were in a state of loading, but immediately got the pages loaded and I have for now as I write this a very responsive system.

  • When in Chrome (my default browser, I sometimes get no response, then a beachball, then more often than not an "Aw Snap" or Kill page? which make me suspect a network issue (all other devices are happy with my time capsule - iPhone apple TV and iPad - yes I am 100% Apple here)

I contacted Apple Support with this story as a Yosemite issue and was told to re-install snowleopard which came with the machine. I want to make sure my iMac is borked first since then I will upgrade to a newer iMac instead.

The fact that I am now breezing along with no issues and pages loading and switching much faster than under Mountain Lion makes me want to first investigate if there is something you guys can detect based on some test you can suggest.

enter image description here

Hardware Overview:

  Model Name:   iMac
  Model Identifier: iMac8,1
  Processor Name:   Intel Core 2 Duo
  Processor Speed:  2,66 GHz
  Number of Processors: 1
  Total Number of Cores:    2
  L2 Cache: 6 MB
  Memory:   4 GB
  Bus Speed:    1,07 GHz
  Boot ROM Version: IM81.00C1.B00
  SMC Version (system): 1.29f1

UPDATE If your iMac slows down and hangs like mine, have a look in the console for hardware issues. An SSD in addition to the 4GB I already had resulted in a fast iMac.

1

There are a couple of Things you could try:

  1. run "Disk Utilities.app" from /Applications/Utilities and start 'Check Volume' and 'Repair File Permission' there are probably some issues here
  2. start the "Console.app", also found in /Applications/Utilities/ and check for errors while starting
  3. Clear the Caches either by starting the Mac in single User Mode (press and hold the shift-key while starting up) and restart the Machine again. Best would be to run 'Onyx' and clear out the Boot Cache.

Don't forget that spotlight would be reindexing your machine after an upgrade, so that could be an explanation for the slow performance at first.

  • Yikes. Console was a good suggestion – mplungjan Jan 1 '15 at 11:55
  • I am pretty sure it's a hard disk issue :( kernel: disk0s2:I/O error – mplungjan Jan 1 '15 at 12:02
  • You could change the Drive to an SSD - it will work wonders on the performance! – J.C. Jan 1 '15 at 12:05
  • Can I change the drive in this model - and is an apple SSD not a 3rd of a new box? I see a pretty hairy process here ifixit.com/Guide/… – mplungjan Jan 1 '15 at 12:07
  • 1
    Since the HD has an external Thermal Sensor you can change it with any SSD - you just have to attach the Thermal Sensor to the SSD or the iMac will increase the Fan to max. Speed. If the change is too complicated you could ask an apple Retailer if they change it for you (for a fee of course). – J.C. Jan 1 '15 at 12:35
0

I tried very many things in a similar situation (beachballs all over the place, system unusable).

Activity Monitor said system was not being used for anything (95% idle, memory mostly free, no apps hogging anything or "red")

Tech tool Pro said no problems. Disk Utility found no problems PreferenceCleaner found no problems

Forced spotlight to reindex

Removed unnecessary preference panes and startup items.

Checked all USB devices and connections.

Logged in with different user and same probs.

one of the error messages was "kernel: CoreStorageGroup::completeIORequest - error 0xe00002ca detected for LVG "Macintosh HD" (EE74B25C-0D2C-49B5-BF7D-EFF4D0D4EA18), pv F035EDD4-32D0-4718-B83B-2D61C774E567, near LV byte offset = 320161787904. kernel: disk1: I/O error."

This is what finally fixed it

System Controller Reset:

http://support.apple.com/en-us/HT201295

  • Great. I put an SDD in and now it's perfect – mplungjan Jan 24 '15 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .