41

I have installed citrix receiver on my home macbook. It auto starts on login yet it does not show an entry in the Login Items tab under the Users and Groups pane of System Preferences. How can I disable the service from starting on login?

0

7 Answers 7

22

Like @cheezsteak mentions, starting and stopping is done through launchctl. The process below allows you to stop autostart at boot.

First, I fetched a list of all "citrix" processes that run on startup:

launchctl list | grep citrix

In order to remove them completely from starting up automatically, I use the following commands:

launchctl remove com.citrix.ServiceRecords
launchctl remove com.citrix.ReceiverHelper
launchctl remove com.citrix.AuthManager_Mac

The only issue now is that when you open the Citrix Receiver application, you may get something like the following error:

Unable to connect to the citrix AuthManager service

To fix this, you manually need to start the services again:

launchctl load /Library/LaunchAgents/com.citrix.ServiceRecords.plist
launchctl load /Library/LaunchAgents/com.citrix.ReceiverHelper.plist
launchctl load /Library/LaunchAgents/com.citrix.AuthManager_Mac.plist

Unfortunately, this is a bit of a cumbersome process. Especially to repeat it every now and then. But I've made it simple as an Automator task, which runs the mentioned commands to start the service and immediately after start the Citrix Receiver.

Actually, I have no doubt that it is relatively easy for Citrix to make this configurable as a preference. There is actually a discussion on their forum about this, but it appears dead and without response. For the time being - and as mere principle - I choose the hard way myself.

For further reference about launchctl, this AskDifferent answer is quite helpful.

3
  • 1
    1-liner: launchctl list | grep citrix | awk '{print $NF}' | xargs launchctl remove
    – A T
    Nov 10, 2018 at 6:08
  • @AT, to let you know. I've tried your 1-liner, but it's not removing all at once, I've to execute them thrice in my case. Apr 25, 2020 at 7:04
  • this is not working for me, when I restart, everything is still there...
    – Chachni
    Oct 25, 2022 at 16:26
13

The following services are are started at login by launchd

/Library/LaunchAgents/com.citrix.AuthManager_Mac.plist
/Library/LaunchAgents/com.citrix.ReceiverHelper.plist
/Library/LaunchAgents/com.citrix.ServiceRecords.plist

You can use launchctl to stop the processes like so

launchctl stop com.citrix.AuthManager_Mac

However I am currently unable to prevent launchd from autoloading these services through launchctl. It is irrelevant because the Citrix Receiver App will not start those services when it starts and will therefore not work if they were stopped or disabled.

I did notice these services are unneeded if using the the companies web app. Considering that one can just delete the above .plist files and only use the web app.

3
  • I do not understand what your solution consists of? What is the answer to "How can I disable the service from starting on login?"
    – Chachni
    Oct 25, 2022 at 16:38
  • @Chachni This was my best attempt to answer my own question. Moriarty gave an answer that seemed to work for more people so I approved that. Granted this was all over 5 years ago so neither might not work with the latest version of OSX. You might need to inspect with what has changed with the launchctl command.
    – cheezsteak
    Oct 26, 2022 at 0:45
  • ok thanks! I gave another answer that is working now for me.
    – Chachni
    Oct 27, 2022 at 1:28
3

Creating an app in Automator with shell script works fine to unload at startup without removing the plist files.

You have to add :

launchctl unload –w /Library/LaunchAgents/com.citrix.AuthManager_Mac.plist 
launchctl unload –w /Library/LaunchAgents/com.citrix.ReceiverHelper.plist 
launchctl unload –w /Library/LaunchAgents/com.citrix.ServiceRecords.plist

Add this app to run at startup and it'll solve the error when you open the Citrix Receiver application.

3

I mainly followed the answer from the Citrix Discussion macOS: prevent workspace/receiver from starting at login/boot.

In short:

  1. In /Library/LaunchAgents, I changed the name of com.citrix.ReceiverHelper.plist to com.citrix.ReceiverHelper.plist_bu just to keep a copy for the future.

  2. I opened com.citrix.ServiceRecords.plist and com.citrix.safariadapter.plist and set the value "RunAtLoad" to "false".

0

I removed Citrix from my mac as it was so annoying. I had to run the code above in Terminal in order to kill the live Citrix first. There were still error messages coming up and I found that there were files with citrix in their name in Library/LaunchAgents and Library/LaunchDaemons, I deleted those, Citrix seems gone from my computer.

For those who have to live with Citrix, I am suggesting keeping the app but getting rid of those launch files anyway to avoid seeing this come up at startup.

0

This has been annoying me forever as well. I tried the above steps via Terminal & to delete the Plists for citrix but would not stop auto launching on my MacBook Air.

The following Citrix Uninstall worked for me & allowed the Citrix Desktop application to be deleted.

The Uninstall seems to do a reasonable cleanup of itself as well.

https://docs.citrix.com/en-us/citrix-workspace-app-for-mac/install-uninstall.html

Finally!!!!

0

Was having the same problem with my new work mac, (oddly enough my old one did not do this) where I really am not supposed to be messing around with system files etc. and do occasionally need to use the app. It looks like as of yesterday(!?) the option to launch at startup or not, is finally a built in toggle in the menu app:

https://docs.citrix.com/en-us/citrix-workspace-app-for-mac/ear.html

Unfortunately the version on my mac is 23.01.1.60 (2301), and tells me there are no updates. Maybe in the next couple of days...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .