1

I lost my old router, and I need to know its MAC address, only info i got is the log of my Mac (Yosemite), i have found that with this command i got a lot of info about the preferred networks (saved networks) on my Mac.

defaults read /Library/Preferences/SystemConfiguration/com.apple.airport.preferences KnownNetworks

And it outputs something like:

"wifi.ssid.<77696669 2d756e65>" =     {
    AutoLogin = 0;
    Captive = 0;
    ChannelHistory =         (
    );
    Closed = 0;
    CollocatedGroup =         (
    );
    Disabled = 0;
    LastConnected = "2014-09-19 19:20:23 +0000";
    Passpoint = 0;
    PossiblyHiddenNetwork = 0;
    RoamingProfileType = None;
    SPRoaming = 0;
    SSID = <77696669 2d756e65>;
    SSIDString = "heeeyomywifi";
    SecurityType = Open;
    SystemMode = 1;
    TemporarilyDisabled = 0;
};

But i see no MAC address :(, could this be done? or shall I search somewhere else?

  • please add the manufacturer and the model of your lost router – klanomath Dec 30 '14 at 18:36
  • 3
    Just to make sure we are solving the right problem here: What do you need the MAC (hardware) address of your lost router for? – nohillside Dec 30 '14 at 18:46
  • @patrix I need it because i want to change some parameters of my network. I cant do it manually entering directly to my router because mi ISP has blocked access to the administration panel from the LAN, nor i can access from the outside, the only way to do it is calling my ISP or accessing to my ISP auto-support web page where i can modify some parameters of my router only if i have the mac address. – David Mauricio Jan 1 '15 at 0:28
  • @patrix, and yes i have tried many tricks like resetting my router, but when i plugin the ISP cable it loads the ISP configuration which blocks all access to common users – David Mauricio Jan 1 '15 at 0:29
2

Pending how long was the last connection, you could find the answer in your Console log.

I have it showing the information for last 7 days. Back to Dec 23. 2014

In Console type MAC in the search window.

Look for MacAuthEvent

In systemlog7.gz file.

EDIT:

If it is older than that:

Use Terminal and type mdfind systemlog

if it shows ....PreviousSystemLogs try that one. (highlight the find and use Reveal in Finder)

If it does not show it in Terminal then look for it in the hidden folder /private/var/db under .cpgz archive that you have to unpack.

  • 1
    LastConnected = "2014-09-19 19:20:23 +0000" :-( – klanomath Dec 30 '14 at 19:03
  • 1
    YOUR time machine backup? ;-) – klanomath Dec 30 '14 at 19:09
  • From what I can see the answer is correct given some constraints, most prominently the fact that the computer must have (re-)connected to the router within the last seven days. So I don't think it will solve the problem described by the OP. – nohillside Dec 30 '14 at 19:27
  • I run mdfind systemlog on my Mac here, there are no ...PreviousSystemLogs at all. – nohillside Dec 30 '14 at 19:31
  • Nice. On Snow Leopard is appears as kernel[0]: Auth result for: xx:xx:xx:xx:xx:xx MAC AUTH succeeded – Vic Dec 30 '14 at 20:32
0

You can check the arp table on your mac. From terminal

arp -a
  • 1
    Arps are cached for a very short amount of time. – ecnepsnai Dec 30 '14 at 18:29
  • Yes, tried and only showed last 3 connections – David Mauricio Jan 1 '15 at 0:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .