0

I currently have Yosemite and I am new to mac.

I have an issue with my keyboard. I tried to look under preferences of the keyboard but couldn't find the proper virtual keyboard matching my actual keyboard which means that not all my real keys correspond. I am playing a guessing game to figure out where "à" is for example. My actual letters are good but not the rest (punctuation, etc...)

The last thing is the continuous shift key. It doesn't "capitalize" mu numbers which means that i need to keep pressing shift at the same time I am writing numbers. Is that a mac feature or can I change it? It's annoying if I have to write series of numbers...

Thank you

  • You should really split these into separate questions - that's how Stack Exchange works. One question, one answer - makes it easier for future users to find answers. – Tetsujin Dec 30 '14 at 14:24
  • yes caps lock never gives me the numbers. It stays these characters: &é"'(§è!çà – Nidale Dec 30 '14 at 22:44
  • No thats not it. U know when u press shift and numbers come up when you type ? With the caps lock, numbers never show up. In windows, thats how it works. without the caps lock, you get characters, with the caps lock, I get numbers. but here, I never get numbers – Nidale Dec 30 '14 at 22:53
1

I have the same issue than Nidale except that my physical keyboard layout is correct according to the APPLE's layout:

  • AZERTY physical keyboard
  • Configure as French Numerical (so 123 underneath the french flag icon)

The issue was solved simply by clicking on the flag in the menu bar and choosing the same keyboard layout as Tom asked to add (french flag with 123 underneath).

The keyboard layout set when you open a document (or an app) will stay the same until you change it manually. If you want to use the numerical layout you need to choose it as default and then close all your apps/documents or relog/reboot (even better).

0

1 I really don't know which "Alter sound" you have heard, it's really hard to guess

2 do you want to type "à"? US_en keyboard layout you can type and hold "a" key and you can see a popup menu like this

3 which keyboard layout do you use?

  • Hey No, I used an AZERTY keyboard for which I cant find under preferences the keyboard corresponding to my actual one. The letters work correctly; however, lets sqy the characters along the numbers, I cant find a keyboard that has that exact sequence under french keyboards. – Nidale Dec 30 '14 at 21:01
  • currently it types : &é"'(§è!çà) What my keyboard shows is : !"#€%&/()=! How do I do a custom keyboard... why would apple provide keyboards that dt match in the pc.. there must be a better sln no ? – Nidale Dec 30 '14 at 22:49
  • I completely agree with you. its crazy. I am going to upload a picture of my keyboard. Ill edit my post. – Nidale Dec 30 '14 at 23:00
  • Where did you get this keyboard? – Tom Gewecke Dec 30 '14 at 23:02
  • Directly with the pc, here in Dakar – Nidale Dec 30 '14 at 23:04
0

To have the numbers stay when you do Caps Lock, go to system preferences/keyboard/input sources and use the plus and add buttons to activate the French Numerical layout, then select that one in the "flag" menu at the top right of the screen.

  • That doesnt work. It only writes in capital but it never changes the keys on top from characters to numbers -- I am set on french numerical just like you asked – Nidale Dec 30 '14 at 22:56
  • In the top right of the screen do you have a French flag with 123 underneath it? – Tom Gewecke Dec 30 '14 at 23:04
  • No, no 123 underneath it. Just the flag, regardless of the french keyboard I pick - even numerical – Nidale Dec 30 '14 at 23:06
  • Can you not click on that flag and change it to the one with the 123 underneath it? – Tom Gewecke Dec 30 '14 at 23:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .