1

I would like to know how to subscript/superscript "single" character in Text Edit. I have followed this question: Entering superscript text (exponents) in TextEdit?, which is format-font-baseline-Subscript but it subscripts/superscripts single line, even if I highlight single character. I tried to use different fonts, but it seems like I cannot select single character and then subscript/superscript it. Thank you for every answer.

  • What OS, what language? It works fine here on Mavericks, UK English – Tetsujin Dec 30 '14 at 13:24
  • If you are talking about typing characters right after one which you have super/subscripted, you do need to reset that function to Default to get back to the normal baseline. – Tom Gewecke Dec 30 '14 at 16:34
1

The problem was that I had plain text turned on, instead of rich text . ( Format-Make Rich text ). I don't know if plain text is the default option or not, but when you have plain text you can't use subscript/superscript single characters, it just applies the transformation to the whole line. Surprisingly, when you subscript something in rich text and then switch back to plain text, you get this popup: Making a rich text document plain will lose all text styles (such as fonts and colors), images, attachments, and document properties. I just don't get why these unsupported operations aren't greyed out when they don't work properly.

  • Interesting, I had never noticed this behavior before. Ideally such formatting commands should not be available in Plain Text mode, or you should get a message asking if you want to convert to Rich Text. – Tom Gewecke Dec 30 '14 at 18:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .