7

I've been dealing with an issue for a very long time, I feel like it used to be a problem randomly, but at least for the last few months it's persistent. The Finder no longer lists mounted Disk Images (.dmg files) in the sidebar. Not for DMGs, nor external hard drives / external media.

The volumes are listed in Disk Utility, and I have resorted to using that to gracefully unmount the disk image. When a volume is mounted, it is possible to access it by it's /Volumes/<Volume Name> path.

Finder, Volume, Finder Preferences, Disk Utility

In this screenshot you see Finder's Sidebar preferences. You can see that I have a DMG for Clementine open, and Disk Utility confirms that. But the volume isn't showing up on the sidebar. You can also see that the Devices list is expanded, listing my built in volume.

I've done some light searching of options to see if it could be controlled by a plist defaults setting, but I haven't found anything yet.

Why aren't mounted volumes showing up on the sidebar? How can I restore them in the list?

This problem began under Mavericks, and has persisted in Yosemite.

  • apple.stackexchange.com/q/98300/1346 is related, but in their case the devices section of the sidebar was collapsed. The screenshot indicates that is not the case for me. – Jason Salaz Dec 30 '14 at 10:14
  • the Finder doesn't show the hidden file by default, so you can paste the code to the terminal to confirm GetFileInfo -av xxx(you must change xxx to the mount point) – nelson Dec 30 '14 at 10:57
  • I have updated my answer – markhunte Dec 30 '14 at 11:28
6

Update.

Just realised that it the CDS,DVDS, and iPod option in the Finder side bar prefs control showing of DMGs

enter image description here

You need to check it to get them to show up.


The below may be related to External drives not showing up.


If you drag them of the sidebar they will never show up even when mounted.

To get them back you need to mount them and drag them back on.

This may not be what is going on with your if this is happening to any new items you have never mounted before. But you could try this and see.


Here for illustration a Partition and a DMG being dragged off. (But this has happened to me without me realising or for some unknown reason.)

enter image description here

enter image description here


To get them back I would need to drag them back.

I go to my device window:

enter image description here

And drag them back to the side bar

enter image description here

enter image description here


And now they are back.

enter image description here

  • Funny, because disk images are none of CDs, DVDs, or iPods. But they're modeled after CDs enough that it makes sense. I guess. Thanks for figuring this out! Checking that option was enough to get them to show up again. – Jason Salaz Dec 30 '14 at 22:32
  • I actually found that checking "External Disks" was what made my Disk Image visible in the Sidebar. When I opened Finder preferences, the checkbox for External Disks had a dash in it (presumably reflecting the fact that it was showing an external hard drive in the side bar, but not the Disk Image I was looking for). When I clicked it, the Disk Image showed up in the Sidebar and the dash changed to check mark. – eipi10 Jun 8 '15 at 18:49
  • FWIW, the dash seems to reflect having dragged at least one item of that category out of the sidebar, preventing it—but not other items of its type—from ever showing there again. My favorite setup makes use of this: I start by checking "Hard disks", "External disks", and "CDs, DVDs, and iPods", then drag out the "Macintosh HD" and "Remote CD" items, leaving "Hard disks" and "CDs, DVDs, and iPods" both with dashes. Thus, by default I have no "Devices" section at all in my sidebar, but it shows up whenever I need it (i.e. when I plug something in or mount a disk image). – George WS Jul 20 '15 at 5:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .