1

In text editor my quotation marks keep getting replaced by non ascii versions.

So if I am editing an XML document the double vertical line type quotation mark keeps getting auto-replaced by the curly type that breaks the XML document.

I have turned off the Text replacement option in preferences but it keeps happening.

  • 1
    Is the text editor you are using TextEdit or another one? Please add this key information within your original question (and not within comments which fate is to disappear). – dan Dec 29 '14 at 18:43
1

If you are using TextEdit, go to Preferences > New Document > Options and uncheck the box for smart quotes:

TextEdit preferences

You may then require a system restart.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .