2

At one point I tried to download an app (game) and it started well, but my iPad crashed during the process. When I now try to re-download the app, it shows the following message:

You've already purchased this, so it will be downloaded now at no additional charge.

Tapping OK, the app refuses to download. How can I download the app?

Screenshot showing message in App Store

Edit: Instead of resetting my iPad, please let me know if there is any other option?

  • Can you download it on your computer and sync it to your iPad? Did you restart your iPad already? Logged out from the App Store in the iPad and logged in again? Does the app show an icon on your iPad already? – nohillside Dec 31 '14 at 12:52
  • Thanks for responding at last yes I tried all those but none worked that is why I am worrying. @patrix – dh47 Dec 31 '14 at 13:03
  • 1
    you get the same problem when downloading on the computer? – nohillside Dec 31 '14 at 13:08
  • Yes the same problem when I do on computer too – dh47 Dec 31 '14 at 13:11
  • 1
    Backup your phone at first, erase all content and setting and restore from backup,it should be OK – nelson Dec 31 '14 at 13:28
3
+25

The most probable source of your problem is Apple just changed their terms and conditions for the App Store and they won't let you download anything till you accept them.

Whenever Apple change their terms and conditions, the App Store app has a strange behavior (since I had an iPod touch in 2008). One typical situation is that it won't let you download an item that you had already bought.

What you should do is install a new app (one you have never downloaded). Then it will take a lot of time and finally (and hopefully, otherwise you should kill the App Store app and begin the process again), the new terms and conditions page will appear for you to accept them.

Once you accept the terms and conditions, you'll be able to download your previously downloaded app.

As you see, the problem doesn't have anything to do with the iPad crash but with the coincidence in time with the terms and conditions change.

2

Does it still not download after you turn off (power off all the way via holding sleep button for 3+ seconds and sliding to turn off) and turn back on the iPad?

That's always solved this for me.

  • no not worked.. – dh47 Dec 31 '14 at 14:39
  • 1
    The only other thing can suggest short of Reseting the device and reinstalling is trying a force reboot. Hold the Sleep/Wake button AND the Home button until the device reboots and a white apple appears on the screen. Sometimes, though rarely, that will clear something a regular restart will not. If that doesn't work, then backup your device and (as cullub says below) "Settings > Reset > Reset all Content and Settings" and then restore from your backup. – lbutlr Jan 2 '15 at 2:16
  • 1
    To clarify, turning the power off and back on (what you call a "regular restart") does not restart the device in the traditional sense like with a computer; it's more like the hibernate mode on a computer, where it doesn't draw any power but restores to the same state as when it was powered down. The hard reset (what you call a "force reboot") is what actually turns it off and back on again. This clears out RAM and many other things that power off/on does not, including permanently erasing deleted apps and their data. (If you don't hard reset after deleting an app, its data will remain... – tubedogg Sep 3 '16 at 17:52
  • 1
    ...on the device. This can be shown by deleting then reinstalling an app without doing a hard restart.) – tubedogg Sep 3 '16 at 17:53
0

Try resetting your iPad.

Go to Settings > Reset > Reset all Content and Settings

Make sure you have backed up your iPad, so you can restore afterwards.

0

Have you checked to see if the game is already on your iPad? If it is, try deleting it.

Is it an iPad 1? The latest version that the iPad 1 runs is iOS 5.1.1. Double check that the game supports your version of iOS. Some apps will install but crash immediately. The game developer may have updated the compatibility since then.

The App Store entry for Amazing Ninja says iOS 6.0 and above. That doesn't mean it actually works on iOS 6, let alone iOS 5.1.1.

  • No the game is not on my Ipad and my device is ipad mini with ios7 – dh47 Jan 3 '15 at 1:29
0

I ran into this problem on my wife's iPhone 6s and iOS 10.1.1 -- but only for one particular app. I could download other new apps without a problem.

I couldn't fix it, ultimately I had to install via iTunes. I tried all the measures listed here except wiping the phone.

You must log in to answer this question.

protected by bmike Nov 27 '15 at 2:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .