5

A picture is worth a thousand words.

enter image description here

I have a shortcut (not sure what the official word for this is) to my Applications folder in my Dock.

When opening it, I see multiple copies of the icon "Xcode.app".

If I "open in finder", I only see one. If I open the launchpad I also only see one.

Don't mind the folder called "Xcode 5", I added this only yesterday while this multi-icon bug has been there for over a month....

Running OSX 10.10.1

UPDATE: The official name for those shortcuts are "Stacks" (http://support.apple.com/en-il/HT201955)

  • Have you tried removing that icon from the Dock by dragging it out, and then recreating a new one by dragging in the Applications folder? – IconDaemon Dec 29 '14 at 16:39
  • Just to clarify, the icons are not in the dock itself, but in the Stack (that's the official name) representing the Applications folder. And yes, I tried removing the icons - it doesn't really remove it. – nute Dec 30 '14 at 7:52
  • I understand that the icons which are being duplicated are in the Applications folder. The troubleshooting step I provided here turns out to be the answer @nelson wrote up below. – IconDaemon Dec 30 '14 at 13:52
  • You are not right: those shortcuts can be in two forms - stacks or folders. See a screenshot in my answer below, section "Display as". – Anton Chikin Apr 14 '15 at 18:30
2

This issue may be related to the preference configuration file.

Delete the stack and re-recreate it, it should work.

  • a mother account? – nute Dec 30 '14 at 8:01
  • Yes, goto "system preferences"->"User and group" ,create a new one, and you can login into the new account. this just for test, you can delete it at anytime. – nelson Dec 30 '14 at 8:04
  • If you meant "another account" - then yes I created a new account, and there XCode only appears once. – nute Dec 30 '14 at 8:05
  • 1
    sorry for typo. delete the stack and re-create it, have you try it? – nelson Dec 30 '14 at 8:13
  • The english you wrote made no sense. I have edited your answer to be clearer. It needs to be approved by StackExchange. – nute Dec 30 '14 at 8:46
3

Right click Applications in Dock, remove it from Dock and then add again. enter image description here enter image description here

1

Run free utility Onyx (http://www.titanium.free.fr/onyx.html), tab Automation, check all operations. This shall fix extra icons (and many other inconsistencies too) after reboot :)

  • This worked for me. – Asciant Feb 21 '15 at 7:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .