0

I haven't made a single change to my wireless network over the last few months. However, lately, my macbook pro will NOT connect to either of the 2 SSIDs that I have broadcasting. Both wireless networks are using WPA2 PSK.

The one that it will connect to is using WPA2 PSK as well. I have like 8 devices in my home that are connecting to this wireless network, and I can re-connect all of them just fine. Even disconnecting some and trying to connect the laptop will not work.

Is there any way to do like a hard reset or something with the wireless profile? This is very annoying. No changes have been made on the WLAN, so I see no reason why I'm having issues.

The only thing that I've done on my Macbook Pro lately was delete my old KeyChain profile, but since I'm "forgetting" the wireless network and re-adding it, I don't see why this would have any effect.

I've tried changing the wireless network password to "Password1", bringing the encryption down to WPA instead of WPA2.. Still nothing.

  • This could be a hardware problem, have you checked allready at an genius bar? – Jules Dec 28 '14 at 20:50
  • No. I don't think it's a hardware problem. It's not that wireless isn't working at all. I can connect to 1 out of 3 wireless networks, all which use the same encryption and password. Thanks for your feedback. – alt Dec 28 '14 at 20:51
  • Could it be that maximum number of devices for that router is reached? – Jules Dec 28 '14 at 20:53
  • I don't think so. While there's several devices connected, the 2nd router only has about 2 devices. If I try disconnecting my phone and tablet, I still can't connect. Let me try again and I'll post back in a second. – alt Dec 28 '14 at 20:54
  • You could try to delete the wifi option and than add it again umders system pref. > ethernet – Jules Dec 28 '14 at 20:55
1

I know you probably already tried this but in an effort to point to the problem being with your Macbook Pro can you connect to a network that is not yours? (e.g. a friends or someone else's?)

Also, you've probably done this too but sometimes just a reboot may help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .