My portable external Toshiba hard drive is now unreadable on my MacBook Pro early 2008 aluminum computer. Since updating to Yosemite OS X 10.10.1, I cannot recover my files stored as Time Machine backups on my external drive. In the finder, it cannot be see under devices, however in Disk Utility, it is visible. The mounted partition is not viewable, however. My own native hard drive is 200 GB while the external hd is 500 GB. There's no creating a 500 GB image on my hard drive, in other words. I've tried the latest versions of Paragon NTFS and Tuxera NTFS with no avail.

How am I to recover my files, most importantly my Time Machine backups, from my external drive?


  • Could you include a screen capture of your Toshiba external disk status as seen from Disk Utility?
    – dan
    Dec 28, 2014 at 10:30

3 Answers 3


Connect your HDD to Windows computer and check&fix it (it is under properties of that drive).

After that reformat the drive to HFS+ if you want to use it with Time Machine. NTFS is not supported filesystem for Time Machine why did you started to use it in the first place?

  • Because it was supported. Not anymore. And it doesn't show up under My Computer at all when plugged into any Windows computer.
    – AlleyOOP
    Dec 27, 2014 at 23:12
  • Sorry it wasn't never was. support.apple.com/en-us/HT201250 If you really used it on NTFS volume you might have been using some workaround which is not supported. And I recommend you seek help on site. I mean go to Apple Service provide and state your problem. Because judging by your questions and answers I assume you might do more harm to HDD if you to go further by yourself.
    – iskra
    Dec 27, 2014 at 23:28
  • I was never asked to reformat, but Toshiba does provide drivers with the hardware that allow the computer to access files without reformatting. Toshiba NTFS drives work all the time around my office for Time Machine backups so I can't explain what the article linked claims. I was never prompted to reformat my drive and I was able to use Time Machine without an issue until the update.
    – AlleyOOP
    Dec 28, 2014 at 4:38

This happened to me with a WD external 1TB hard drive (where I kept Time Machine backups) right after doing a clean install of Yosemite. The drive would be visible in Finder, sometimes it wouldn't, and even thought it would mount, I was unable to access the drive via the Finder or Terminal. It had some sort of denied access. It sounds similar so hope this helps...

If I recall correctly after all the troubleshooting, I found that the permissions on the volume were changed for some reason. The user did not have read nor write access. It was completely removed.

If you get to see your drive in Finder, select the volume (drive), and hit Command-I. This will bring up the "Get Info" page where at the bottom you can see the users who have access to the drive. If you don't see your user, add it. You should be able to use your drive now.

Let me know if this worked as I can investigate further the steps I took. I just wanted to provide a quick response from what I remember worked.

  • Unfortunately I cannot find my drive in Finder at all.
    – AlleyOOP
    Dec 27, 2014 at 23:13
  • → AlleyOOP: Is this because within Finder Preferences you don't show External disks? Since you see it within Disk Utility your disk is perfectly recognised by the system and perfectly readable.
    – dan
    Dec 28, 2014 at 10:25

Try getting another external, then Disk Utility/Restore. That will reformat the external, so copy all data off it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .