1

I've been trying to learn to automate my home Mac environment with Applescript. I've had some success, but am running into seemingly inconsistent and troublesome errors. In order to diagnose the errors, I've broken the scripts down into their component parts and narrowed the most troublesome issue down to the Screen Saver. When I activate the current screen saver via a script, or if I access the Screen Saver control panel via the System Preferences, I get

enter image description here

I can click the "OK" button and it dismisses, sometimes for good, but most often it loops endlessly and my only option is to force a restart by holding down the power button. I've tried force quitting all open apps, and relaunching the finder and the error message/dialog box loop remains running.

Oddly, starting the Screen Saver with the Hot Corner does not seem to trigger the error.

To me this indicates that the issue isn't with my script, but that there's a problem with my Mac.

For what it's worth, I've also had issues with connecting to my Time Capsule backup which is the only drive on that server.

The machine is a MacBook 13-inch Late 2007 running OS 10.7.5.

Thoughts?

Update -

I thought that the Screen Saver might have been trying to call up images from a drive that used to be connected to the Airport Extreme but that is no longer there. I reset the Screen Saver control panel to one of the built in Screen Savers (after many tries at dismissing the irksome dialog box) and I deleted my user defined Screen Savers. This did not resolve or change the issue in any way. I've tried the same AppleScript on two other Macs without incident. Both of these other Macs are running 10.9.5 though, so that may or may not indicate anything.

Is there a way to re-install just the Screen Saver, or should I try to re-install the entire OS? Is there something else I should try?

Thanks!

Update 2

Well, re-installing the OS did not resolve the issue. I tried deleting the preferences plist from both the user library folder and the library folder at the top level of the hard drive. This didn't resolve it either. Perhaps it's an issue with the Airport Extreme, though I can't imagine why the Screen Saver in a re-installed OS would need to access the Airport Extreme. I'm really stumped here and beginning to wonder if I'm going to have to pay for more expert help. Thoughts?

Update 3

It occurred to me that though the Screen Saver should not be trying to connect to some external volume, it still might be. I used to have a number of hard drives connected to, and shared by the Airport Extreme. One of those drives stopped mounting reliably, and as it so happens, it's the one with my pic archive and iPhoto files on it. I took it to a local shop and they worked some low level UNIX magic on it and recovered my data to a new, larger drive. This new drive is now connected to my RAID 1 server Mac Mini, not the Airport Extreme. When I mount the volume with the pic archive to my desktop first, there is no error message. Dismounting it and running the script or opening the Screen Saver control panel prompts the error message. Help?

0

OK, I got it solved. I first mounted the disk with the image files from it's new, permanent location on the server. Then I opened iPhoto and slowly, image by image opened them. The bulk of them opened with no problem from the new location. A fair number, 100 or so out of 10,000, had lost their connection to the actual file. Most of these I was able to locate on the hard drive and re-link with no problem. A few, perhaps 20, I seem to have lost completely. None of them were of much importance. I allowed iPhoto to take it's time quitting so that it could update it's library etc. Now, even without that drive mounted to my desktop, the Screen Saver will start with a simple AppleScript and opening the Screen Saver control panel works with no trouble and does not spawn any error messages at all.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .