0

I was trying to install CLI package from github but I messed up during the process and ended up getting this error. It is persistent and won't go away. Terminal wont accept any commands like mkdir, ls, clear screen. To fix this error I ended up deleting the info.plist file for the terminal ( I am not a very smart person) which somehow bricked terminal and it won't start anymore. I decided to download iTerm, and it still launches with the same old error. What am I supposed to do. Please help me .

enter image description here

1

Well the error you're getting sounds like you've tried changing the $PATH variable somewhere. Possible candidates (not all of them need to exist) are

  • /etc/profile
  • /etc/bashrc
  • ~/.bash_profile
  • ~/.bash_login
  • ~/.bashrc
  • ~/.profile

Find all lines starting with export that contain the path you've posted above in those files and prefix them with a # to disable them. Restart iTerm and the error should be gone.

Regarding the deleted .plist, do you happen to have a TimeMachine (or other) backup that you might recover it from? Before re-installing everything you could also test creating a new user and copying the file from this account to yours.

| improve this answer | |
  • Well it actually might not have a PATH= in front of it and that is the problem. – 0942v8653 Dec 25 '14 at 11:16
  • @Asmus where do I find the lines starting with "export PATH" it has been 3 days since I've been with the error – Nash Vail Dec 25 '14 at 13:10
  • Also I don't have any kind of backup – Nash Vail Dec 25 '14 at 13:30
  • @nashmaniac for a quick fix open iTerm, and enter export PATH=/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin this should give you the default tools back. Test with echo $PATH . – Asmus Dec 25 '14 at 14:11
  • 1
    @nashmaniac I've updated my answer to give you an idea where to look. – Asmus Dec 25 '14 at 14:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .