2

My Mac mini (early 2009) was getting slow, so I decided to do some upgrades. I got 8 GB of ram and a 128 GB SSD from crucial that their wizard verified as being compatible. I downloaded Yosemite from the app store and made a bootable USB drive following Apple's instructions. Then I did a time machine backup to an external drive. Finally I did the RAM and SSD install. I inserted the Yosemite USB drive I made earlier and did a fresh installation. On startup, I migrated files and settings from my time machine backup. I logged in to my primary account and did the software updates from the app store and rebooted. At this point my family started using the computer and is very happy with it. Startup, login, and application loads are very fast. There's no more freezes or beachballs.

However, one of the four user accounts is problematic. It takes several minutes to login and load the dock/ menu bar, versus seconds for all the other accounts. Clicking on anything in the menus/desktop/dock/dialogs results in a beachball for several minutes. No applications or files will open. Occasionally I'll get a "the application ... could not be opened" error dialog 10-20 minutes after trying to open something from the dock. How do I fix this account?

Some additional information: this computer does not have filevault encryption enabled, and there are no login items.

  • try fixing the permissions in disk utility. – Ruskes Dec 25 '14 at 1:33
  • or try fixing that user specific permissions using the ACL's reset. – Ruskes Dec 25 '14 at 1:41
  • @Buscar웃 I repaired disk permissions using a different administrator account, which did not have an impact. I also verified the disk, which shows it as ok. I cannot run disk utility under the affected account because that account cannot launch any applications. What do you mean by "try fixing that user specific permissions using the ACL's reset"? – JC Hulce Dec 25 '14 at 1:45
  • Permissions problems may make things not work. They will never make things work slowly. I would be more inclined to suspect hardware. A disk sector (even on an SSD) that requires multiple reads to get past a soft error can have a dramatic impact on speed. – ganbustein Dec 25 '14 at 1:50
  • @ganbustein what would I use to diagnose that? I've done SMART tests and the verify disk thing in disk utility and neither indicated any problems – JC Hulce Dec 25 '14 at 1:58
0

Use/hold Command-R during restart

select Terminal and type "resetpassword"

Then select reset password for the account in question

DO NOT RESET the Password.

Instead click on the Reset Home Folder Permissions.

ACL

  • This worked! However, it was missing a step. I couldn't find the reset password option so i did some googling. I had to go to the terminal and type "resetpassword" to bring up this screen. I also repaired permissions again with disk utility and it fixed one thing that it didn't find before. – JC Hulce Dec 25 '14 at 2:18
  • Upon subsequent logins, the problem is present again. Only the first login to the account after the permissions reset is free of problems. – JC Hulce Dec 25 '14 at 4:23
  • Sorry, I was busy with stuff and did not pay attention. – Ruskes Dec 25 '14 at 4:41
  • 1
    Update: I tried some additional steps and was able to completely eradicate the issue. I reset the permissions for all users and root. In Finder, I clicked "get info" on the applications folder, and applied the permissions to all enclosed items. I shared and unshared the folder. Then, I did the public beta update to 10.10.2. Everything appears to be working great now. – JC Hulce Jan 5 '15 at 3:26
  • good job, feels good when you fix stuff your self :) – Ruskes Jan 5 '15 at 3:35
1

There is likely a corrupt preferences or other file in the user's ~/Library folder. Honestly your best bet is to create another users folder for that person, copy their files over and set up Mail, Messages, Safari and the like from scratch.

Once you have a working profile you can slowly migrate other things from the old to the new user folder (old Mail folders, Safari bookmarks, etc.) till you have enough restored for everything to work as necessary.

At that point you can delete the old user.

0

So. I've had this same problem with multiple machines. I've tried all these fixes. Sometimes they work, sometimes not.

the last one that got this app lockout error would not work after reboot/recovery/resetpassword/ACL reset, or re-install operating system, or re-install operating system and add user again.

turns out that accounts that have been migrated a few times (from OSX 10.6.8 to 10.10) end up with broken "parental control" preferences, somewhere deep in the settings.

the fix was to set up parental control for that users, grant them everything, reboot, then remove parental control, then reboot.

all fixed.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .