1

I have a Seagate GoFlex home 2 Tb external drive that was installed on my Snow Leopard Mac and configurer with Time Machine. A year ago, due to issues with my Mac, the (internal) hard drive was erased and I subsequently installed Mavericks and re-configured Time Machine with the external drive. I would like to retrieve the files from the Snow Leopard backups, which included many photos for example but I am unable to see them in Time Machine. I can only see the Mavericks backups. Here are additional things I tried:

  • I tried accessing the external drive via Finder but nothing appears in the Time Machine backup folder. I obviously also looked in the other folders and for hidden files but nothing relevant appears.
  • I looked at the Seagate GoFlex applications that were included with the drive but none of them allow me to access the backups, including the Mavericks backups.
  • I tried the Migration Assistant (under Utilities) and I can only see the Mavericks backups.
  • I checked my Time Machine settings and "tell me when old backups are deleted" is enabled. I would have been noticed (which isn't the case). I also read that new backups can override older ones but my disk still has 1.5 Tb free.

Thank you for your help!

  • 1
    once you're inside Backups.backupdb > [My machine] > [date] or 'Latest' then everything else is just a file structure, browsable like your original drive… If it's not there, it got old & was erased – Tetsujin Dec 24 '14 at 21:21
1

The Time Machine backup format is OS-version agnostic. It doesn't care which version of the OS created the backup or which version is trying to access it.

It does care which machine is accessing the data. As far as TM is concerned, erasing your internal drive turned it into a "new" disk volume. The stuff it backed up before the erasure and the stuff it backed up after the erasure are backups of different disks and have nothing whatsoever to do with each other. That's why when you're browsing the backup of your current disk you can't see further back than when it was created.

This can be fixed, but only if you are mistaken when you say I tried accessing the external drive via Finder but nothing appears in the Time Machine backup folder. This can't be right. Your Mavericks backups, which you say exist, should show up in Finder.

If you look on your backup volume, you should see a folder named Backups.backupdb. Inside that is a folder for every computer you are backing up there. I'll assume there's only one. Inside that folder are a bunch of folders, almost all of them snapshots named according to when they were taken, in the format YYYY-MM-DD-HHMMSS. There will also be an alias name "Later" and maybe a few other folders. If that isn't what you see, I don't know how to help you.

Open TM and see how far back in time you can go. Make a note of that date and time. Exit Time Machine.

In Finder, browse through the list of snapshots to find the latest one from before that oldest Mavericks backup. That was the last snapshot taken from before you erased the disk. If there isn't one, if the oldest snapshot is one you can reach with Time Machine, you're out of luck. You must have erased your TM backup when you set up TM to start backing up the new disk, and your old data is gone.

But if you can find such a pre-erasure snapshot, we can re-associate it with the new disk. That is, we can make TM treat it as a backup of your current boot disk.

To do that, log into your admin account and open Terminal (in /Applications/Utilities). Enter the command

sudo tmutil associatedisk -a / 

but don't press return yet. Be sure you left a space after the slash. Open up that pre-erasure snapshot, and you will see a folder for each disk you were backing up at that time. (There's probably only one: your boot volume. That's the one we want.) Drag that folder (the one for the snapshot of your boot volume) to the Terminal window. Drop it anywhere; Terminal will put it in the right place.

Press return. If you've never used sudo before, you'll get a scary warning message, which you should read but ignore. You'll be prompted for your admin password, which you need to type blind. Nothing will be echoed to the screen. Press return at the end of the password.

Time Machine should now be able to browse backwards across the erasure.

  • Thank you so much for your comment. I looked into accessing Finder and got to view my Mavericks backups, but unfortunately I think that the Snow Leopard files were deleted. I will look for an application that could restore deleted files and hope that I could get back my older backups that way. – chlorophyll Dec 26 '14 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .