20

I just updated a contact's phone number in the Mac Contacts app. Now I want to call them on my iPhone (4S), but my iPhone does not have the new number. Both the Mac and the iPhone are configured to sync to my iCloud account. How do I force them to sync now, one after the other, so I can make this call?

  • Try switching the Contacts tab under iCloud settings on your iPhone. If not, can you check if that number is in iCloud.com? – bretonics Dec 24 '14 at 18:13
  • The change has not made it to icloud.com – ShadSterling Dec 24 '14 at 18:41
  • 1
    It seems your Mac is not uploading to iCloud or you might have added that contact under the contacts of an email account. Check your iCloud settings on your Mac and open the Contacts app. Check if contact is under the iCloud account by selecting the iCloud account alone, NOT "All Contacts". You will see different accounts (emails) if you allowed contact syncing for your email accounts on the Mac. – bretonics Dec 24 '14 at 18:45
  • The only place I see "All Contacts" is under "iCloud" in the vertical pane on the left. The place that says "iCloud" cannot be selected, clicking on it does nothing. The only other thing there is "Smart Groups" (which cannot be selected) and "Last Import" (which can be selected, but has No Cards). – ShadSterling Dec 24 '14 at 18:53
  • Unchecking and rechecking the Contacts option in the iCloud control panel did not trigger a sync. – ShadSterling Dec 24 '14 at 18:54

10 Answers 10

4

To summarize, follow these steps:

  1. Close and reopen the Contacts application. Did that work?

    Side Note: Generally contacts will sync whether the app is open or closed, it doesn't matter, but sometimes devices act up. It tends to happen with older devices, especially if running newer versions of iOS (iOS 8).

  2. Try switching the Contacts tab under iCloud settings on your iPhone. If that does not work, check if that number is visible in iCloud.com
  3. If the phone number is not there, it might be one of two things:
    • Your Mac is not uploading to iCloud.
    • You might have added that contact under the contacts of a different email account setup on your Mac.
  4. Check your iCloud settings on your Mac and open the Contacts app, taking note if the contact is under the iCloud account by selecting the iCloud account alone, NOT "All Contacts". You will see different accounts (emails) on the left hand side if you allowed contact syncing for email accounts on the Mac.
    • If so, drag-and-drop the contact to the iCloud tab.
  5. To confirm whether your Mac is uploading to the cloud, login to iCloud.com and check the Contacts app. If you don't see the new contact, you know to focus on the Mac to iCloud sync.
  • To be clear, my iPhone 4S with iOS 8 wasn't acting up - the problem I had wasn't between the iPhone and iCloud, it was between the Mac and iCloud; the contacts app I closed & reopened was the one on the Mac. After I did that and refreshed the browser tab to confirm the change had been propagated to iCloud, the change had already been propagated to my iPhone. – ShadSterling Jan 10 '15 at 0:45
  • Ok great... you describe a problem in step 5 without providing a solution. – Sparky Nov 6 '18 at 15:50
10

I assume it's a little late for your phone call, but for anyone else with this problem you can force both the OS X and iOS Contacts apps to sync with different methods.

OS X
Close (and reopen?) the Contacts app.

iOS (8)
Touch Groups on the top left, then drag down until the spinner at the top fills up.

4

The real simple way to force Contacts to be updated is to add a new contact. I add a new contact with a First Name of "A" and click done. My contacts are then updated from the cloud. Then I delete the new contact. **It works both ways - iPhone to Contacts and vice versa.

3

Great way to force a sync is to go to iCloud settings and sign completely out and then sign back in - it forces a complete sync and solved my problem with this issue.

1

If you have multiple accounts on your phone such as your iCloud account as well as your work account it is possible that the new contact has been added to the wrong account.

Go to Settings->Mail, Contacts, Calendars and scroll down about 2/3 of the way to the Contacts section and make sure that iCloud is the Default Account.

enter image description here

If you find that you have been saving contacts to the wrong account there currently appears to be no way to move them to another account using the iOS device. The best way to fix this is to either export them from one account and import them to the correct account then delete from the original (wrong) account. You can also accomplish this via emailing them to yourself from the iOS device.

1

I had this issue on the Mac side (icloud.com and iPhone were in sync). The accepted answer (open/close contacts.app) did not work in my setup (OS X 10.13.2). Nor did a reboot or checking/unchecking "Contacts" under iCloud in System Preferences.

What did work, however, was signing out of iCloud on my mac, letting it remove local copies of everything, and signing back in. This is a nuclear option as it requires re-syncing, downloading multiple gigabytes of iCloud data in the process. You MUST ensure what's in iCloud (icloud.com) is the version of truth you want before proceeding down this road.

But it did work.

0

Reboot your iPhone. iCloud contacts started syncing immediately for me. It might work for you.

0

Solution: 1) Default account on all devices needs to be iCloud. 2) You can select all of your contacts in OS X and drag them to "iCloud > All iCloud" in Mac OS X Contacts to get them all into the proper account (and thus syncing and showing up on your iOS devices). Apple will even handle the duplicates for you automatically.

0

The iCloud contacts disappeared from my iPhone 6 for no reason. These iCloud contacts were still on the iCloud website, iPad, and mac, but they were not on the iPhone. I tried everything apple suggests on their website several times (https://support.apple.com/en-us/HT204150), but nothing worked.

Then I tried turning on Gmail contacts from anther account and magically, the iCloud contacts synced. Why knows why that worked, but it worked for me.

-1

You can also try to click the circle / arrow thing in the upper left corner in the Contacts app.

  • In Contacts Version 9.0 (1563) there is no circle / arrow thing in the upper left corner. In the leftmost panel there are groups, with no icons at all (unless you count the window close/hide/expand buttons). In the middle panel there is a search box with a magnifying glass icon, and a clear button, but no other icons. In the right panel is the contact information, the upper left of which is the contacts picture or the placeholder icon. I see no "circle / arrow thing" anywhere. – ShadSterling Mar 25 '15 at 23:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .